Flipsky 6.6 not updating firmware (but it kind of is)?

Alright so I got everything hooked up last night and got my Flipsky 6.6 Pro hooked up to VESC Tool. I tried updating the firmware and it seemed to update correctly and it upgraded from 3.53 to 3.62. But whenever I run the FOC setup and get to “run detection” for the wheels I get this error: unknown-2

After which if I go back to the firmware page it says that I am running 3.62 which is the latest version:

If I hit check version after that it’ll then say 3.53

And if I dont run FOC setup qizard and I hit check vesc version it will stay at 3.62. I’ve tried running the bootloader but to no avail, I still get the same error when using the FOC setup wizard. Anyone know a way around this or what might be happening? I’m not getting anything in the faults screen either.

This has happened to me a couple of times but only while setting up input. I usually just close the dialog box and try again a couple times and it works then.

Yeah I tried around 5 times but was met with the same error each time, I even tried power cycling. I’m hoping to at least be able to input the values manually tonight.

I had this isdues with my 4.2 plus the second vesc woudnt update via canbus so i had to treat them as seperate vesc even then updates took 2 or 3 goes to work via seperate usb. Updates since have been fine. Its like when you create a mismatch of firmware canbus features stopped working. With one side updated i could see the second vesc but not update it. Try removing all uart devices. Controllers and metr ect.

I share this issue. My reciever is mounted just above 1 of the USB ports. So while your in the vesc tool. Try again to setup input. If you get the same error go to bottom left corner and choose the other vesc id. Try again. If you get same error go to connections and click the “can” tab to highlight it green and repeat the process stated above. 1 of 4 of these attempts should work. Lmk.