FlipSky Dual FSESC4.20 switch failure

Hi all,

I have a FlipSky Dual FSESC4.20. It has been working well for the past few weeks; however, now the switch does nothing and the ESC powers up automatically when connecting the xt60. Previously it would require the switch to activate the ESC due to anti-spark function. Any Ideas how I can resolve the issue? I have tried another switch and it still does nothing.



I am sure you have tried this. With everything unplugged. Can you unplug the switch cable. Then plug the battery in?

I did try that but unfortunately it didn’t do anything. The ESC turns on automatically when I connect the xt60 and I still cant use the switch to turn it on or off.

have this problem also. Would like to know why. Did the vesc failed or the switch failed.

One if the MOSFETs failed short circuit. This is expected. Flipsky is working on a better design to replace them with.

Is there any solution to solving it without having to purchase a new ESC? @Gamer43



Have you tried using a loop key on the negative end of the power to the VESC?

If the VESC is still working but just can’t be turn off, I think loop key might be a possible solution :+1:

1 Like

Yes you can, but you will need a heat gun or hot air station and confidence in your soldering abilities.

Something like this but on the negative side? @jun1208

Credit: hyperlon1

Yeap that’s right :+1:

That’s of course if the VESC is working when you plug the battery to it, because if it works when you plug the battery to the VESC that means it has just bypassed the anti spark switch so a AS loop key should work as a switch in the absence of the built in AS switch :slight_smile:

1 Like

Perfect. The VESC definitely works so I will put one together this week and see how I go. Thanks for the help mate, much appreciated.