Flux Linkage Detection Failed - Vesc-Tool

Hey guys,

I’ve been running into an issue while programming my vesc during the motor detection setup and haven’t been able to troubleshoot the issue. I’ve scoured tons of posts of people hitting the same error but they’ve all been for seemingly different issues, or their solutions haven’t worked for me - so I thought I would make my own post.

Some context about my parts: I’m running a 10s2p battery connected to an anti-spark switch via xt-60 connectors, feeding into my Flipsky FSESC4.12 via an xt-60 connector - which then connects to my Flipsky 6374 BLDC motor via 3 bullet connectors.

Here’s my issue: during the FOC motor detection (“Setup Motors FOC” button) in the (latest) VESC-Tool, I configure “Medium Outrunner” -> set the battery parameters (10s and 6.0 Ah), then on the motor detection window after hitting “Run Detection”, my motor first makes a small screech and vibrates (seemingly what it’s supposed to do from other videos), then attempts to spin up much faster. Upon this second spin - it rotates quickly for about a second - then instantly stops spinning and just vibrates for a couple seconds then shuts off. I get the error popup: “Flux linkage detection failed.”

My troubleshooting attempts to help any suggestions:

  • Resoldered bullet connectors on VESC
  • Re-arranged phase wire orders
  • Soldered bullet connectors (made sure they were perfectly soldered) on a brand new Flipsky FSESC4.12, tried again and had the same error - which makes me believe this is not a vesc issue.
  • Reflashed the firmware and bootloader on the vesc

I think this is a motor issue - but I’ve hit this issue on an identical Flipsky 6374 motor before on my exact same board with the same parts and setup (about a week ago), and somehow got it to work in the motor detection, it spun up fully, set all my parameters, and was working fine. I’ve tried for days on this motor now and can’t get by this issue with this one. This motor is brand new, but the sensor wire connector is broken so I’m running it sensorless, the other one I had sensored.

Let me know if you’ve had this issue before and know what may be causing it. I know this is a long post - but hopefully the comprehensive information gives you a better idea on what the issue may be.

Thanks a ton.

1 Like

have you tried buying a lacroix?


trying another ESC and motor would be ideal…