Flux linkage detection failed

Hey guys, I was setting up my VESC, and I connected everything and started running motor setup. But when I tried to run detection, I got a warning saying “flux linkage detection failed”. what does this mean and how do I fix it? I looked in this thread

but it didn’t solve my issue.

I’ve had this problem… but I forget how I solved it. I believe it was with basic trouble shooting. Start by restarting the tool and your device. Make sure that all connections are tight. Run detection again. If the problem is still there. Switch up two of the three motor wires and give it another shot. Make sure to start from scratch with the Wizard. Don’t load the settings that are on your vesc. An old setting could be interfering with a new setting.

I did all of that already. At first I thought it was a problem with the hall sensor, but t happened even when unplugged. And no matter how many times I swapped the 3 motor wires it still happened. I hope it’s not a problem inside the motor or the VESC itself, because them’s expensive.

I think the hall needs to plugged in for the linkage. If you test it without the hall make sure to set up the ESC as “sensorless”. Have you ever damaged your motor wires?

Is this a new build. Have you checked to make sure your halls wires are wired correctly?

I’ve set it up as sensorless but it does the same thing. It starts clicking, then spins slowly, but as it picks up speed it stops and just vibrates. Then it gives me the error prompt.

It is a new build. The hall sensor needs soldering, but it’s not connected so it doesn’t matter yet.

its-probably-the-flux-capacitor

3 Likes

well. I think I busted it by sending too much current through. Now it flashes pink. Not a good sign at all.

What ESC are you using? Could you post some screen shots of your settings and possibly the error message?

just happened to me. took me two days to finally detect a bad soldering in one of the bullet connectors. it was holding in place by the shrink sleeve so sometime there was a bad connection and sometimes no connection.

Hey guys, so I had the same problem with the Flux Linkage detection while setting my motor up with BLDC but when I set it up with FOC, it worked perfectly.

How did you fix the problem?