Focbox connection Issue


I’ve started experiencing an issue my unity. I can power it on and everything works fine, but then the connection is lost. The remote still shows as connected but I can not accelerate or break. As well as this, the power button will not turn the board off again and shows no input when being pressed. To turn off the board I need to unplug the vesc from the battery. This issue arose last night when I was out on a ride and the acceleration and breaks started cutting out after riding over tactile paving at crossings.

To resolve this I’ve tried unplugging everything from the unity which has fixed the issue momentarily before cutting out again, after moving the board. I’ve also tried securing and taking out the bluetooth module with no luck. I thought this might have been the case since I had difficulty connecting via the vest tool app, where it would connect and a few second later disconnect and show “read firmware version”. Because of this, I tried updating the firmware and reprogramming the motors. I’m considering buying a Metr pro unity smart blue tooth module but I’m not sure if this will solve my problem.

Any help or ideas on how to fix this issue would be much appreciated.

1 Like

Are you familiar with soldering ?

Could be a bad solder joint,could be a bad connection at your remote PWM, could be a short in the motors phases f*ing the unity.

It could be. When I looked inside after first experiencing issues I could only see that the Bluetooth module on the unity had come out. But after reinstalling and securing it back in place I still experienced the cutouts. I also tried removing the bt module entirely but still experienced the same issue. All of my components are fairly new as I only built my board in May of this year. The issues have only appeared after changing from pneumatics to caguamas. I feel like maybe it’s the vibrations from the less smooth ride that are knocking the components and causing cutouts. On my most recent test, I barely made it to the end of my street before my board completely shut off and disconnected from my remote, and when I got back and took off the enclosure, again the bt module had fallen out causing it to short circuit. But if it’s an issue with the bt module, then surely I shouldn’t experience any issues by removing it completely?

the BT module has nothing to do with your issue. I’m almost 100% on that.

Hot glue all of your connections when they’re connected solid to further debug is my advice. Do it on a private road and try and trigger vibrations…

If you experience braking during first vibrations- look into motors…

After adding some foam padding to my enclosure where the unity is secure down the connections and testing it round the block, I haven’t experienced any of the issues so far. I have no hot glue atm :frowning: but will do this if the issue arises and persists again. Thanks for the advice! :slight_smile:

please read again as a “MUST” gluegun goes on your buylist as of now :smiley: