FOCBOX, failed detection - defect focbox?

Hey guys,

I’ve encountered a problem with my focboxe. it was running fine in FOC For the last few weeks. The last days it was running, it would detect a bit higher values for the foc motor detection. But still would run fine.

I took down the board to redo the battery pack and switch wheels. Now after connecting everything again it constantly fails motor detection. The motor is just stuttering and hardly turning. What I‘ve done so far:

  • Reflash Firmware, motor detection in BLDC & FOC both failed. I tried the original firmware as well as akmaniacs.
  • Changing phase wires, tried each combination. Failing as well.
  • I don’t use the hall sensors. But I still tried Sensored and sensorless. No difference.
  • I checked the motor cables for continuity and they all seem fine.

Would this point to a defect FOCBOX? Is there anything I can check on the board/measure ? I will make sure to upload a video later next you guys can see what I mean by stuttering.


Do you get a error msg in the terminal after the detection?

Terminal tab, type “faults”

No fault codes detected :confused: I’m pretty sure settings are all correct. I’ll show a pic of the real-time graph when I do motor detection later when I’m home.

Whenever you disconnect your sensor/phase wires you often have to run motor detection again.

Ok thats a good sign, probably some parameter is throtteling the motor detection or a broken phase wire

I’ve done around 10-15 motor detections for now. With all possible phase wire combinations and firmware reflash and and and… can I conclude that the phase wires are fine if I get continuity on all of them ?

Have you tried doing motor detection without the sensor wire plugged in on bldc? Do that, if it works then do motor detection again with sensor wires plugged in. Apply. Then do FOC detection.

Well not really, if you have a bad solder on a connector, no mater what combination you’ll have the same result.

What motor are you using and what is your battery?

A pic of your setup would help

AH Okay, I’ll resolder connectors first of all when I’m home then. The setup is a 190kv aps 6374 on a 10s4p and focbox. Photos and videos when I’m home

Well don’t necessarily need to resolder them, i’m just giving hints to where to look for a problem.

Could be worth checking your input voltage also

Did you try motor detection on a different motor? Have you checked the board for burnt parts?

Ok guys, have made a video. You can see the failed bldc motor detection and the stuttering. Changing cables do not make a difference in the behavior. I also can’t move the motor properly with the arrow keys. FOC is behaving the same way. !WARNING! turn down the volume

1 Like

Do you have any picture of the Mosfet side…

They look fine to me :confused: R2 looks weird but I just checked its just the glue

Did you try what I suggested???

Yes, tried that before :slight_smile: The sensor never worked for me, even before that. Still no difference though.

1 Like

Someone pointed out a failed detection and rised the detection current from 6A to 8A and that worked.

I’ve read that somewhere too and tried that. Motor just stutters harder at detection :sweat_smile:… Anyway, @Blasto has messaged me and offered me to take care of it. Apparently some of the FETs/gates are soldered on really bad. And I’ll get a new unit in return ! Real class act :smile:

1 Like

I just took a closer look at the FOCBOX and noticed that R6 is missing. Can anyone confirm that there should be a resistor there ? Its right next to the USB plug.

Did you do the correct orientation of the sensor wires? The label on the focbox is wrong