Frequent DRV8302 Faults? Help me troubleshoot! (With telemetry)

Frequently I am getting a DRV8302 Error while riding, but otherwise the board functions fine. When this occurs, the VESC abruptly cuts out. In one example, you can see I went from 24mph to 12mph in less than a second (Example 1). Needless to say, the transition from 30A to 0A is very jarring. It has nearly sent me to the pavement a few times. Once or twice has even briefly applied a braking current of up to -20 motor amps! Talk about wobbles…

In total I have received the DRV error at least 6 times, but it has been more frequent as of late. Typically I get the fault code while climbing a steep hill, so I thought it may be related to high current draws. But today I received the same error on flats in the first 3 minutes of my ride, while pulling only 11A (Example 2)


  • VESC v4.12 (2.18 firmware) - from DIY
  • SK3-6374 149kV @ 12S
  • 18:34, 15mm belt drive on 83mm wheels
  • FS-GT2B Remote (stock)

Troubleshooting (Tried all of these, and still received error after):

  • Removed belt and re-performed motor detection
  • Reduced motor amps
  • Reduced battery amps
  • Check for loose connections. Taped phase wires
  • Checked for potential shorted pins on the VESC


Example 1:

  • DRV8302 Error


Example 2:


VESC Settings:

It sounds like your DRV chip is failing. They don’t always die in one massive boom, sometimes it’s more of a slow death. Unfortunately, since your description seems to indicate it getting worse I’d say slow death. Mine did something very similar.

Still post your settings, especially the advanced tab. Maybe we can see what if it was caused by a settings issue.


Did you also remove the motor pulley to do the motor detection?

I did a comparison just the other day. motor detection with motor pulley on and again with pulley off. It made a difference in the bemf coupling by 100 points


Thanks @Namasaki! I did not realize the motor pulley would make that much difference. I will brave the red loctite removal and rerun the motor detection. I posted a screenshot from the current motor detection settings (belt removed, but motor pulley still affixed)

I was afraid of that… It’s been working great for most of the year, and only starting giving the DRV in the last month or so. Unfortunately I did not buy a VESC with a warranty (this time…)

I updated the original post with my VESC settings. Please take and let me know what you think. The soft battery cutoff is set fairly low, because I have found that is anything but “soft”

Sorry to be the bearer of bad news: guaranteed you have a dead DRV chip. On the advanced tab, the max current ramp step has maxed at 50 (should be about 0.04). You have the buggy version of firmware 2.18.


Nice catch, thank you! I even checked to make sure I did not have the current ramp bug when I first got the VESC, but clearly I missed it

I reprogrammed it using a value of 0.004 for the current ramp step, so it ends up at 0.04 after one configuration write. I’ll install new firmware when I have time (either the native firmware for Metr, or the one for watt control)

After a quick test, it feels much better and no errors yet. But I didn’t push it very hard. Only pulled around 15A max on somewhat flat ground

What’s the back emf coupling?

Yep it’s official. This VESC is going to kill me. The DRV chip is definitely failing. Received the same error charging up a steep hill today. Continued on riding without stopping, but that transition from +30A motor current to -23A braking current… wow. It gave me such serious “whiplash” that my front hand nearly slapped the pavement. Good thing I was in a race stance with a lowered CG or it definitely would have tossed me…

Pretty disappointed in DIY/TorqueBoards for selling a VESC with bugged firmware, months after the bug had been reported. It ended up frying my VESC and could have seriously injured me on multiple occasions. Going to hit up @chaka for a legit VESC with a warranty. Ollin’s product support has been stellar so far

Yeah, it was a very unfortunate bug. I fried 2 DRV chips (though I soldered my own VESCs, so it wasn’t as big a deal for me since I could just replace them myself). I wish vedder had made the fixed version 2.19 instead of keeping the same version 2.18, cause it’s pretty impossible to tell if it’s the buggy one before loading it.

My rule of thumb is to just reflash f/w no matter who I get it from. Or just flash Ackmaniac’s f/w.

chaka once said that he doesn’t think this bug has any effect on the drv issue, but from all the examples, I’ve seen, I don’t think that’s right.

The problem is I was fairly new here and didn’t know who was a reputable download source (before I learned how to compile it myself)

I’m fairly confident the bug definitely caused (or at the very least accentuated) DRV error

Just to clarify I mean that I don’t believe chakas claim was right and i definitely do think it has led to some burned VESCs

1 Like

It seems to make sense to me that a high current ramp step could be the cause of the DRV error. I interpret this parameter to be the maximum allowable change in current per time step (or the maximum rate of change of current). Every time I received the DRV8302 fault was after a high current flux (e.g., while climbing a short steep hill, or after accelerating hard from a rolling stop)

Well now I’m stumped… I replaced the suspected faulty TB VESC with a brand new Ollin VESC 4.12. After configuring all the settings and running motor detection, I got another DRV8302 error while bench-testing at max throttle. The error occurred after less than one minute of use. The VESC reset and there was no permanent damage as it still works fine. But I can’t figure out what could have caused the DRV error again. Any ideas?

My two theories were a faulty DRV chip or a battery problem. I’ll spare you the details, but after lots of troubleshooting the battery is fine. The VESC is brand new. I took everything apart and checked for cold solder joints. There are no shorts and the phase wires are taped

What could be the source of the non-latching DRV8302 error on the brand new Ollin VESC?
@Jinra @rpn314 @chaka

Here is the Metr log which shows the DRV error while bench-testing. Notice that the error occurred while only pulling 1.4A

What motor are you running?. Is it a cheap hub motor? I have a few other customers frying hardware on a those cheap little bastard motors.

It’s an SK3-6374 149kV from HobbyKing. Single drive

Was just editing my post after I read your initial post. What mode are you running?

Also, what battery are you running? Are you using a BMS?

BLDC mode. Never touched FOC. Running the stock firmware included with your VESC right now

Battery is 4x 3S Zippy 40C 6.2Ah wired in series. I am in the process of building a 12s4p 30Q battery

SuPower 60A 12S BMS

If the VESC is toast we can throw another one at your build but you might have something else going on with your board. I would check that motor as best as you can for broken windings or a possible short where the phase wires enter the motor housing. Keep us posted with what is going on with it and we will help you out the best we can.

1 Like

The VESC is still good. Nothing is blown. I ran it on the bench after the error and wasn’t able to replicate it. Even after getting dozens of DRV errors on the old TB VESC, there was never any permanent damage to the speed controller after it reset

But… Thanks to your suggestion, I think I found the problem

Broken motor winding. You can see an impact mark on the windings and one strand is clearly broken

So the good news is it’s not the VESC. Bad news is I spent $500 replacing the VESC and building a new battery, only to figure out I need a new motor :sweat_smile:

Or at the very least, I need to redo all the windings