GT2B Remote Issue

I recently did a mod on the GT2B controller to make it more small and portable. I had issues with it in the beginning but worked them out in the end. It was work for about a week, I changed all the necessary requirments on the BLDC tool. Then today I turn on my board to connect turn the remote on and pull the throttle but nothing happened. I open my enclosure and see that one of the motor wires were unplugged, so I plugged it back in, pulled the throttle, and nothing happened. I tried charging the remote to see if it was low but that didn’t change, throughout this whole process the remote was binding with reciever. But after plugging the charging cord into the controller it stopped binding. I tried using the video everyone recommended on binding but nothing happened. This is my second remote mod and both have not worked for very long. Is there a better remote to buy that is comparable or any ideas as to what is going on?

Did you by chance solder anything to any part of the trigger pot?

I’ve done 3 or 4 GT2B -> smaller 3d enclosure w/o issue. Are you sure it’s the Tx? Try another and it works?

Looking in the remote - any bad solders? Pics might help.

Sucks - i’ve always thought the GT2b was the ultimate robust remote…