GT2B won't turn on. Solved kind of

I did a basic gt2b mod a while back and the remote has been working great until now. The timeline goes as follows.

-About 2 months ago I hooked up my receiver and remote and it worked great.

-Couple weeks later the red light started flashing whenever the remote was on but it still kept working great.

-The other day I rode it on campus and it worked perfectly for half the day, then I went to turn it on and no lights or anything. Almost like a totally dead battery. I plugged it in to charge for about an hour during which time the green light was on so I assumed it was charging. Then an hour later I unplugged it from the charger and tried turning it on. Nothing. Later that night I flipped it on and it turned on! Light still flashing but it was on! Then within 15 seconds of riding my board it felt like it was throwing out a sketchy signal (board was jumpy) and then the lights went off and it was dead.

What have I done so far? I took it apart and checked for any shorts or opens and there was nothing. I looked over the circuit board and nothing looked burned out or disconnected. I tried another 3.7V battery and it didn’t turn on at all. I also checked the switch by shorting it to see if it would turn on and it did not.

I would like to ride my board this weekend when I go to visit family so I’m really trying to figure out my remote situation ASAP! Thank you for any help!

Any luck on your problem?

My GT2B is completely dead now. Plugging into USB does nothing and no LEDs turn on anymore :frowning:

na man I wish some people would chime in but maybe no one has any idea what’s going on. I just really need to get it fixed before this weekend!

Well this was my solution. Haha

Maybe the battery died or something got damaged through an impact, like a broken solder spot. Screw it open and look over everything. If you find something broken, solder it. Measure your battery if its ok. If everything looks good, battery still ok but it simply won´t work properly, just get a new one :+1:

1 Like

Mine is still stock, so I can’t speak for Kaden, but it has the same exact symptoms he is describing. My GT2B’s lipo is currently at 2.90V, so I think a low voltage cutoff must be active. I question whether my remote’s charging circuit ever even worked correctly

@Kaden56 was your red or green light flashing? My red LED was solid, and the green was flashing. Charging LED would not light up, even when plugged into USB. But now no LEDs light up

Maybe I can figure out a way to hook that little 1S lipo up to my balance charger…

Mine had a solid red and blinking green while It was on. I tried it with another 1s battery and still nothing.

Well I “fixed” my dead GT2B by rigging up a balance charger directly to the 1S lipo. Attached wires with Kapton tape and charged at 0.8A (1C)

The remote works again. Solid red power LED and solid green status LED. But plugging a USB charger into the remote does not indicate it’s charging at all. Shouldn’t the charge LED blink red? I am wondering if the FS-GT2B has a problem with the internal charge circuit…

As soon as the low battery light starts blinking, you need to be charging up. 2.9v is well into permanent battery damage territory. There are a few recovery methods which should be done very carefully and visually monitored 100%.[quote=“jmasta, post:8, topic:17621”] Well I “fixed” my dead GT2B by rigging up a balance charger directly to the 1S lipo [/quote]

Note that the little GT2B battery is a Li-ion not a LiPo.

Turns out that was the problem with mine too! The battery just wasn’t actually charging when I would plug it in via usb. The battery finally just completely died. I got an old spare 3.7v lion battery from an old camera and tested it to see if it was the battery and I thought I could rule out the battery being the issue cause it still didn’t work. Turns out that battery was just completely dead too! I charged it up in the camera and then took it out and put it into my remote and it worked! So until I get my nano x receiver fixed and back from enertion I’ll be taking the battery out of the enclosure and charging it in my camera and then putting it back into the remote.

So this brings up something interesting though. Why are mine and some others gt2b’s batteries not charging via the usb port after modding them? I did a very simple mod too. No relocation of the usb port or anything. Just cut off the excess part of the CB on the side and then soldered the pos and neg wires to the battery. Any ideas?

Its a LiPo. It says so right on the battery

You could have stressed the board and created microfractures, try reflowing the components, maybe a via is damaged too, you can grab a multimeter and check for continuity. throughout

My GT2B will not charge. Plugging in a USB power source does nothing. And my remote is still 100% stock. No drops or damages. No mods.

Same problem as @Kaden56 it seems. But it helps narrow down the problem to the actual FS-GT2B, and not a case mod or USB relocation issue

Are we looking at the same picture? It clearly says Li-ion.

Li-ion Polymer… aka LiPo :slight_smile:

Side note: To what voltage does the GT2B charge it’s battery at full capacity? It seems like charging to 4.20 or even 4.15V might not be ideal since it takes so long to discharge the battery. I stopped mine at 3.85V. Would one of you mind measuring a fully charged battery? Thanks!

Sorry guys, you’re both mistaken. Google it…:slight_smile: Li-ion is not Li-Po…

A lithium polymer battery, or more correctly lithium-ion polymer battery (abbreviated variously as LiPo, LIP, Li-poly and others), is a rechargeable battery of lithium-ion technology in a pouch format. Unlike cylindrical and prismatic cells, LiPos come in a soft package or pouch, which makes them lighter but also less rigid.

Guys, Please do some Googling. You are confusing Li-Po’s with Li-Ion. They are different batteries. Probably better to let the thread get back on track.

Maybe we are using a different google machine. LiPo’s are a form of lithium-ion batteries. Most cell phones today use LiPo’s, despite them generally being referred to as simply “lithium ion”. LiPo’s are li-ion; squares are rectangles. Li-ion is not necessarily LiPo, just as a rectangle doesn’t have to be a square

Anyway, we are tying to figure out why our GT2B’s are not charging…

1 Like

Not confused. Knowing battery technology is my job. Yes, Lithium-Polymer batteries and Lithium-Ion batteries are not the same. Lithium-Polymer batteries DO NOT exist in the consumer world, you rarely see them in the industrial world and are more often seen in academia. The reason the technology has not developed is because it performs poorly at room temperatures.

What most people refer to LiPos in the consumer world are Lithium-Ion Polymer cells. All RC batteries in the consumer market are Lithium-Ion Polymer batteries. The difference in what we call Li-ion and Li-Po is the packaging and slight chemical changes. The cell in the picture by those standards is a Li-Po.

You can read more at: Don’t tell people they are mistaken without backing up your statement with some actual data or citations. Makes you seem like an ass no offense…