Has anyone used these VESCs - Green Motion?

maytech vescs are garbage. Their motors are good but the vescs are useless for anything over 10S and only do 10S for a little while before they burn.

3 Likes

Cause anyone can assemble a decent motor. Electronics though is a lot harder.

Well I am only going to be running on 8S for now, however would be nice to be able to run VOC and tryout bleeding edge stuff without fear of things going bang. Thinking I might try and return the item and buy something of better quality.

Can anyone recommend the VESC from proto boards? https://www.proto-boards.com/product-page/vesc-speed-controller

The VESC Tool is for beta testers only right now but should be released soon :grinning:

If by harder you mean they find it difficult to pay a couple cents more for higher quality components and maybe pay a little more attention to how things fail and adjust their processes accordingly, then yes. So much harder. They’re doing none of that. The parts fail because of greed, not because China can’t produce amazingly high quality parts. Nothing is keeping maytech parts from being Ollin or AXLE quality other than they have deliberately decided to fully maximize profits at the customer’s expense.

So yeah, its a lot harder to not make quite as much money and instead produce a higher quality product when your only mission is to maximize profits by impregnating the market with quick selling garbage that people buy after doing zero research due to the fact that they can barely contain their excitement over building a board.

2 Likes

I have the question out to Frank and Ben on the VESC-Project forum. Asking when the new VESC Tool will be released to the public. I’ll let you know what they say.

It’s worth the wait folks…

Yes, they certainly can. But my point is there’s a lot less to fuck up with a motor than with the vesc. They need to understand their lack of attention and using low quality parts are not going to work, but how can they when they don’t even test their own product in the real world themselves in china?

It’s either greed or ignorance, and based on your impressions, it’s greed. Either way, they need to get heir shit together.

1 Like

I couldn’t agree more.

Well, I went the expensive route after a frustrating search about what components might be best. I must say, there is allot of conflicting information available in this forum.

  1. many mention VESC is not meant to be used for mountain boards, Chinese or not
  2. many mention that regular ESCs are crap in general/they burn/cannot stand up to the abuse

Conclusion. Not a single ESC/VESC is suitable for mountain boards. :rage: Anyway, I hope the focbox type VESCs will save my bacon when going up and down hill/8 km trips.

You went the right route @telnoi :wink: I’m using dual V4.12 from esk8.de (soon switching to 1.1 controller) and am very happy with the quality and performance. I run them on my mountainboard (and also was afraid because noone recommends it for mountainboard as you said). The performance is great (sensored FOC) for riding. I’ve never tried ESC but I think with ESC you get more raw power if you want to ride as crazy like @Nowind or want wheelie action. But for me the V4.12 are just fine!

Good to hear. I ordered the 1.1 controller mainly due to the enclosure and better protection agains the elements.

Additionally you get less heat problems and there are many added components and they should deliver more power, too. It’s always best to buy quality stuff even when you can’t afford it because in the end you buy the cheap plus the quality one.

So I received my VESC and I can confirm that it does have the buggy firmware. I would like to try and make it stable by updating it to Ackmaniac fireware and BLDC tool.

When I try and upload from the firmware tab, it seems to be working correctly. but when it finishes upload it crashes Ackmaniac BLDC tool, and on restart it says “the connected vesc has too old firmware…” again.

I have also tried uploading Ackmaniac firmware via the standard BLDC tool and although it does not crash and says upload complete, it does not seem to work with the same problem on restart.

I am guessing that it must be a problem with the bootloader or lack of one? It just seems strange that it goes through the process without error, and says upload complete. I have attached a video of this for example.

Can anyone confirm what is going wrong and what I need to do to fix this? Purchase a ST-Link V2?

And no bootloader that’s why you can’t upload FW. You can upload the bootloader with ST-Link V2 or wait for the new VESC Tool where it’s just one click :grin:, should be released very soon.

If you want to use the V4.12 with buggy FW then set the current ramp step to 0.004 and then write configuration (after that the value stays at 0.04 as long as you don’t read or write configuration again).