Has anyone used these VESCs - Green Motion?

Just gathering parts for my first build. Just took a bit of a impulse buy, and bought a single one of these VESCs from ebay user ‘naama1485’ or from ‘Green motion electric vehicle solutions’ based in Israel.

I just wanted to see if anyone on here could shed any light on the quality of these, are they rebranded Chinese VESC Should I avoid using them in VOC?

http://www.ebay.co.uk/itm/Twin-Pack-VESC-BLDC-Open-Source-Electric-Skateboard-ESC-/152533373148?hash=item2383b290dc:g:RyoAAOSwNRdX2smF

Will be posting a build log soon when my parts start to arrive, so we can all see the outcome.

As far as I know they are rebranded maytech from china. They run in BLDC mode but don’t like FOC.

I used may tech before. they died now. they also have old fmw 2.18 with some bug. not recommended

Are the defiantly Maytech then? I was planning on updating the firmware as soon as I got them, is this not possible?

not possible they tells me to buy their STlink. I told them it’s buggy fmw but they deny their fault and blame vadder. i disputed in aliexpress to stop their business. long story short never buy maytech esc.

That looks strange, although it seems you could buy one for cheap on ebay if this is the only way to update FW.

You can also push firmware via new VESC Tool without STLink - once released. Still Beta, but i did this for two older VESC 4.7 with no problem.

Unsure on VESC Tool release… but helps those w/o bootloader (to update fw).

1 Like

well it’s up to u to decide. I know the price is tempting.

You already bought it so there is one important thing to check before using it as @onepunchboard mentioned. I have 2 maytech and both had buggy FW. You have to check your current ramp step setting in advanced tab. It should be 0.04 (mine was 40 :astonished:) Everytime you click read or write configuration this value gets multiplicated by 10. You can test this by clicking read configuration several times and watch the current ramp step value. If it stays equal at 0.04 you don’t have a bug. But if so you have to set 0.004 and then write configuration (after that the value stay at 0.04 as long as you don’t read configuration again). This is the reason why many people fry maytech V4.12. And don’t try FOC!

As @sl33py said, you can wait for the new VESC-Tool for uploading your bootloader and firmware. I did it with both maytech’s and it’s super easy! If you want to do it right now with STLink you can PM me, I ordered a cheap one but won’t use it.

1 Like

@rich. Thanks for the warning. Also have two maytech incoming.

1 Like

Haha, this is a shame! Also I can’t believe they still deliver with faulty FW because they should know. Very funny is the fact that they say “don’t use FOC” or not longer than 10 seconds :joy: but when you look at the manual FOC is an own chapter! But from my experience I know how they perform (or better not perform) in FOC, have tried it once. Now I use high quality V4.12 in FOC without problems. I bought 4 cheap V4.12 first until I realized that I lost my money because of buying cheap!

Thanks for all the invaluable advice, will be sure to check to see if it’s buggy when I get it. So FOC will still not work after a full FW update. Does anyone know the actual reason for this??

Also, if I want to get a good quality VESC that will run with FOC, which are the reputable suppliers?

Also where do I find release info on the new VESC Tool “without STLink - once released”

Is the Flier VESC from Alien Power Systems any good?

Are you in Europe?

Got Greenmotion Vesc. had to install the bootloader using ST-Link and after that reinstalled the FW to fix the Current Ramp bug. Running it with BLDC mode and it works just fine, didn’t try FOC but heard it’s not recommended.

Yes telnoi, I am in the UK.

The two German resellers have stock. Alienpower only appears to have items available for backorder/who knows how long that is going to take.

The maytech/greenmotion has minimum parts only. You need better quality with modified and upgraded parts then it will work. In europe I recommend @esk8 (esk8.de) where I bought mine. Just for info I’ve tried FW 2.18, 2.54 and 3.26 with maytechs in FOC (at home only), everytime hitting the brake (even with no load) the vesc cut off and show up DRV fault. 17 times braking = 17 DRV faults and no braking possible, that’s bad!

:joy: my 2 remaining cheap V4.12 are flier, greetings from china!

You don’t need info, you go to bootloader tab and click upload, that’s it :grin:

I know, it’s absolutely ridiculous. :joy:

Is the beta tool available to a select view or can anyone try it?