Help: brand new ESC is non-responsive

Just wired in a brand new MayTech Dual 50A ESC and got as far as updating both sides, and now its dead. It had old firmware and wouldn’t let me configure it because of it so I updated them to 3.40 (I think) and now both sides cannot be detected by my computer.

I’ve tried 3 cables and 4 USB ports and it still can’t see either side, they literally worked an hour ago

The receiver and METR are both paired and powered so the system is powered still

Edit: it can see the slave side on occasion but I cannot finish the motor detection process before it drops connection, furthest is measuring RL in sensored FOC on the slave after setting the amp limits

Keep trying different cords… not all usb are created equally. some are for data and some are only for charging, you probably have a charging only cable

I tried 2 different cords on each side of the VESC on 2 different ports on my computer…nothing


time to call mods to close this?

1 Like

Maybe not…its not connecting to the computer still. Lights are on but the ports are dead

Black, red, white wire harness is the power switch…Black/brown so on Brown, orange, yellow is the receiver


To the top :crossed_fingers: