Help, my board won't charge!

Hey, i own an AEboard AE1 (which i love). I let my board charge entirely about 2 months ago, i came back yesterday and the thing wouldn’t turn on or charge. This was seird since i had let it sit for more than 2 months before and it still had charge.

I tried charging it with a lab bench supply (charges at 42v 2A since it’s a 10s3p battery), it wouldn’t take the charge.

I disassembled the skateboard and checked the voltage at the B+ and B- poles of the battery, it reads a steady 40.2V which seems normal.

If I check the voltage at the charging port, it reads 37V and drops down to like 8V when i try to turn it on.

By the way, if I plug it in and try to turn it on, the power indicator turns on for like 1/4 of a second.

I don’t know what the problem is… Could it be the BMS since the voltage at the battery poles seems normal ? but why wouldn’t it turn on then ?

Please help, i really love that board and don’t want to throw it away…

Bms is broken. A simple bms bypassing and a new bms for charge only will fix this right up.

1 Like

Thanks for your answer, could you please explain what a BMS bypassing is and would do ?

Basically you’re not discharging via bms, but from the main battery instead. You just solder the negative wire from the battery to your XT connector instead of the bms negative wire. Then you solder the bms wires accordingly. B-, b1, b2, b3, etc. The last b+ wire goes to the positive discharge wire. The b- goes to the negative side of the battery displayed by the old b- wire on that bms.

So you’re replacing the bms.

Thanks, i just tried connecting the battery directly to the ESC board and it turned on and worked ! So I’m guessing the BMS is dead. The original one is a “BZA13_3260_D20C20_10S”. I Believe it means the bms is meant for charging at 20A and discharging at 20A. I couldn’t find an original one tho.

So I bought one rated for discharging at 30A but i now realized it’s rated for a charge of 10A, hopefully it won’t be a problem.

Put a fuse on positive side of the charge wire that connects from the bms to the charger. It will protect you if there is an issue.

1 Like

There is not enough information to know this, and it could be a fire hazard / recklessness to suggest this.


What are the voltages of each P-group?

He was saying that the power wouldn’t remain on or charge. I took that as an bms issue because this also happened to mine. The same with the charging.

Aeboards uses a very small bms that breaks easily due to vibrations. I know this extremely well. I would had suggested other means if he said the voltage was abnormal.

I checked my pgroup and they were all fine. But I agree that he should check his as well. No issues on that.

I agree with @b264 what are the voltages of each individual P group?

If the values are not identical, a conclusion (not necessarily your situation) could be drawn that you have a loose nickel strip in one of the P groups causing unequal balancing amongst cells.


@LeonCamero @Jcullinan09 @b264

My bad I forgot to say, all my p-groups are at 4.02V


I guess i had the right answer in this guess lol. But glad i could help with this issue. Its aeboards. Its known to have failing bms unfortunately.