Help, my motor is intermittent!(Solved)

Hi folk Thanks for any pointers offered before time… so under throttle AND breaking my motor runs on, then off, blipping for maybe quarter of a second then the torque returns for a second, then repeat. Same under breaking, resistance for about a second then no resistance for a quarter of second (approx) then repeat. This problem appeared to start after i had used my board a dozen times. my settings

My stuff DIY electric skateboard VESC 10s (2x5s) 8000mah lipo SK3-6374-168 motor GT2B in baby buffalo form vedder switch Thanks for any advice

I’ve tried a visual inspection of everything from belt to batteries no damage visible on vesc and motor turns freely. Really confused, can’t seem to duplicate problem on unladen board. Are my amp limits correct?

I once had an issue like that with a build I recently finished. It turned out the problem for me was that the heat shrink for the motor wires wasn’t reaching all the way in, and the motors were shorting a little on and off.

Like this??

could also be a dry solder I had a similar problem with an enertion r-spec. solder between the motor windings and silicon cable - very little contact area here anyway, touched it up with some solder and it seemed to be fine.

This is probably not the cause, but you should change your max input voltage to 57v. Also you change the trim on your control to read at exactly 50% when in nuetral, then set your failsafe (button on receiver) and to check it’s working properly you want to turn off your control and it should stay at 50%

already at 48volts - assuming this is a 10s build? 48 should be plenty.

I realize that having it at 48v might not be the cause of his issue, but there is no reason to lower it from the standard 57v

1 Like

Yes 10s I had the no brakes issue and raised it to 48v. It could well be after the vesc. Will tape connection and report back… thanks all

I reset mine and it set to 40v and I raised it (I think) but I am working on more than 1 board atm and get confused as to what I’ve changed and where

1 Like

set them all to 57 as Tito said. it’s there to protect the cells from overcharging but in reality who immediately bombs mount everest with a full battery from their front door?

1 Like

No still bad, gonna get back into the vesc, restore all settings and will up that voltage Then open my motor if necessary, hayho

1 Like

A problem I have had before is the motor screws reaching two far into the motor housing and shorting the coils, you might check that?

No, on the other end, the motor end. Like what the other guys are posting.

Now I’m struggling to remove the gear off the motor shaft, time for a bit of heat, then I can get inside and see whats what


Right, solved,couple of weeks ago forgot to say

The cause? :blush: (mumble mumble mumble…

1 Like

… what was the cause dude?

1 Like