Help Please! Space Cell, VESC, blown fuse on first power-up

Hi All, I just got all the parts and I’m starting on the electronics, trying to configure the VESCs with the BLDC_Tool. I don’t have a bench power supply so I put a smaller fuse in the Space Cell (10s3p), plugged in the VESC, hit the switch, and the fuse blew immediately. Any ideas? Is there a chance the RC receiver, if connected or not connected would somehow request full power without trigger input? Are there any common short locations I can check for on the VESC? I’ve tried it with and without the motor attached. Looking around for tips, most of the VESC troubleshooting begins once the BLDC_Tool is working so I’m not sure where to begin with this challenge. Any thoughts or suggestions would be appreciated! Thanks!

Fuse only blows in extreme situations. First thing I think about: You put + and - the wrong way around.


Thanks. I soldered the bullet connectors on the motor wires, but otherwise I haven’t done anything. Black and red wires line up as they should at the xt60 connectors, and the vscs look like the others I’ve seen online.

what fuse did you put in the space cell?

5A fuse. I have two VESCs and I have tried them both. Once, I saw a very brief blue light from the VESC before the fuse went. Blue, like an LED, not like arcing. Thanks for your time!

Is this a VESC you built yourself? It sounds like there might be a short if the fuse is blowing immediately.

If this is a commercial VESC just use the stock 40a fuse as they’ve already been preprogrammed and are safe to use with proper batteries.

1 Like

Why are you using a 5 amp fuse? You’ll be blowing so many. What Jinra said to use a 40 amp fuse is fine.


I put in a 5A fuse so if something goes wrong when I first plug it in and start configuring, it goes wrong at lower amps. I’ll put the 40A back in when it’s time to ride. I hope there is logic in that. I bought the battery and VESC and the only thing I have changed is adding the bullet connectors for the motors - I haven’t modified or made any other connections.

just use the 40 fuse. The VESC can take a burst current of 240A which should trip a 40a fuse anyway. No reason to configure on small fuses. Your 5a fuses will probably trip during detection as well.


I’ve blown two of those too. Same circumstances, two VESCs, tried separately (each attached alone directly to the battery) on 5A and 40A fuses.

definitely sounds like a short. Have you tried turning it on without the VESC attached? Can you measure the current and voltage with a multimeter?

1 Like

Do you have any picture of your connection?

1 Like

Thank you all! I’ll get a multimeter on it in 7 hours, and take a picture as well.

The yellow and green is just so I don’t confuse the two. VESC 1 has blown a 5, 10, and 40A fuse. VESC 2 has blown a 5A fuse, but just worked with a 10A. That is vesc- battery only, no RX or motor. I’m glad that VESC 2 seems to be working. DMM says 36v from the battery. What else can I check on the VESC? Thanks!

Seen like you have a short, can tou put a picture of the other one… @Blasto

Also, where did tou buy these VESC

1 Like

There’s your short. The red wire is touching the fet pad that is directly to gnd (through the shunt).

Resolder that red wire, nothing should be damaged on the VESC


Nice! Thanks for picking that out! I’ll be able to make the repairs next week.

It works! Problem solved. Thanks! Electrical system is mostly complete, but having problems identifying the hall sensors with the BLDC tool so I’ll try without sensors for now. The hardware will come together this week, and there will be no more kicking.

Good stuff man! Glad it worked out.

You know the procedure now if you want help w your setup, pics of the setup :wink: