Help with a 2 year project

Hey there, I have been building an electric skateboard on and off for about 2 years. I have some free time, so I have decided to finish this once and for all. This is my first ever project like this. I have listed all of the details below.

However, I have a few problems which I haven’t been able to fix so far.


  1. Sometimes, the motors do not spin concurrently when accelerating.
  2. The motors vibrate uncontrollably before beginning to spin when reversing.
  3. The remote is very sensitive , pushing it up or down slightly results in full speed spinning of the wheels on the skateboard. I have tried calibrating it on the remote, however there is no difference.
  4. The remote doesn’t show the correct battery percentage of the skateboard.

All of the issues are shown in the Youtube video.


Motors: Flipsky 6374 190KV 3250W Motor Link

Remote: Flipsky Screen Remote VX2 Pro Link

VESC: Flipsky Dual FSESC4.20 Plus Link

Battery: Slick Revolution Urban Range – 6S4P 25.2V 12Ah 302Wh Link

Deck: Slick Revolution Urban Carver Deck Link

Wheels: Evolve 97mm wheels (Not exact, but very similar) Link

Motor Pulley Set: Banggood Kit Link


Motors: Flipsky 6374 190KV 3250W Motor

  • Max Power: 3250 Watts
  • Max Current: 85 Amps
  • Max Volts: 12S
  • Max Torque: 8Nm
  • Motor Resistance: 0.05Ohm
  • Recommend ESC: 3-12S 50A (FSESC4.12 50A or FSESC 6.6 60A)
  • Weight: 1.9 lb / 0.86 kg
  • The motor length:74mm
  • The motor diameter: 63mm
  • SHAFT: Diameter 8mm, 32mm length, 3x3x20mm keyway slot.
  • Motor Wire: 130mm silicone 12AWG wire with 4.0mm Gold Bullet Connector Male.
    • Wire configuration:
      • Blue = A
      • Black = B
      • Yellow = C
  • Stator: 0.2mm thickness lamination japan steel
  • Magnet: N42SH high temp curve magnet
  • BLDC Motor
  • The number of pole: 14

Sensor Wire: Standard RC Sensor Wire JST-ZH 6pin 1.5mm pitch

  • Internal PCB with 120 Degree Hall Effect Sensors.
  • Motor can be used with or without a sensor. Sensorless operation is most common.
  • VESC Sensor Wires required to use with VESC.

Remote: Flipsky Screen Remote VX2 Pro

  • Color screen
  • Option choice for km/h and miles/h
  • Option choice for FSESC and other VESC( FOCBOX)
  • 2.4Ghz band width
  • Real time data reading and 0.95OLED display
  • Support 3 speed modes
  • Support cruise control mode
  • Remote and E-skateboard power indication lights
  • Rechargeable Li-ion Battery
  • Wrist strap
  • Battery last for 12 working hours 2

VESC: Flipsky Dual FSESC4.20 Plus

  • Hardware:V4.20
  • ERPM:60000
  • Firmware:3.40 (Keep upgrading if FW is updated)
  • Current:50A continuous/single, 100A continuous/dual ,burst 150A/single, burst 300A/dual
  • Voltage: 8V-60V (Cells: 3-13S LiPo,Safe for 3S to 12S LiPo,Voltage spikes may not exceed 60V! )
  • BEC: [email protected]
  • BEC type: Internal driver support
  • Modes: DC, BLDC, FOC (sinusoidal)
  • Timing: Software calibration
  • Cutoff Voltage: Programmable
  • Frequency: PWM input
  • Programming card: No
  • Reverse: Yes
  • Regenerative braking power: Yes
  • Motor wire:12AWG
  • Power cable:12AWG

Battery: Slick Revolution Urban Range – 6S4P 25.2V 12Ah 302Wh

Samsung 30Q 18650 cells

I think the problems may be due to the remote. It may be faulty or broken and causing issues. Should I buy a new one or is there another way to solve the issues? Please let me know below

I am in the UK and due to the time difference I might not be able to reply quickly since I am asleep.

1 Like

Hi @simeonikulin, and welcome to the forum!

Did you already used this e-skate, or only during bench tests?

That can be solved by seting traction control on VESC tool (enable the option)

If it’s during benchtest, it’s normal, it seems super sensitive, but with load on the board, it is usually way less sensitive. Also if your remote is on UART mode,i don’t think there is much to do to calibrate it, as it’s automatically communicating with VESC.

Your remote is probably set on less cells that you actually have.( It might be configurate for 4s and you are running 6s so it thinks it’s 100% charged). To adjust it, press the setting button 3 seconds, press again 2 seconds to change value and chose the right number of cells. Then, press on off button to confirm.

I’m not sure, but connecting hall sensors (and do detection again on VESC tool ) could fix this problem.


I think this is %on reverse ramping. Mine do the same thing but haven’t cared enough change it.

@Crisfell Hey there, thank you very much for replying! I was a little confused which setting you mean’t when you said reverse revamping. I have put a photo down below of the menu could you show me which one to change?

Smart reverse max duty cycle I believe. Increase it. Line below that decrease it to 1 and see what happens.

Hey thank you very much for replying, I appreciate you doing that!

I read your comment and yes, so far I have only tested the board on bench tests (which I presume is just when you put it on a bench or table and test if it works?) and the things you have suggested have been very helpful.

I have put on traction control on both of my VESCs and it has had a very positive effect on the motors spinning in concurrently when accelerating. They now almost always spin concurrently and it is very rare that they don’t so I am glad that has been solved. Thank you very much.

Im a little confused about the battery cells option on the Flipsky remote. I have tried putting 6 since my battery is 6s4p but it still doesn’t show the correct battery percentage.

I have changed it and it has solved the problem! Thank you very much!

1 Like

Yes, that’s it. Usually braking and acceleration seem way more strongs during bench test than with someone on the board.

Once you will test it for real, it can be a bad thing if the value of max erpm traction control is too low as it can dicrease your max torque.

You will see it if motors are cogging going uphill ( or appliying lot of torque). In this case, increase the value. I’m set on 1000 but it depends on the personal setting as wheel size.

For your remote, maybe contact flipsky to see what is going wrong …

When accelerating motors from stopped, it is not uncommon for one to start first (at least when using Flipsky anyway :wink: (as you said Johnny).

They are in torque control, so once they accelerate with no load, they seem very fast very quick, the tolerance between the parts will make one set off first. This is made worse if one belt is tighter than the other. Once you’re riding this is not an issue, as long as both spin in the same direction, I expect it will ride fine.

When you set up the VESC did you notice if the Sensors were correctly detected? As running sensorless really does make the starting of these motors pretty harsh.

After 2 years build it sounds like you’re super close to actually riding this thing!

I’m in the UK too (Sussex), I’ll help more if you send pics. Lol