Help with first time setup vesc: no led blinks on startup, no firmware read response

After putting together my first eboard build, when I tried connecting my vesc to the BLDC tool it says connected for about two seconds then it reads “no firmware read response”. I’ve searched around the forum for people with similar problems and tried their solutions but nothing has worked for me so far. If it helps, when I turn it on (with anti-spark key) the vesc doesn’t blink at all, but my voltmeter turns on and reads 0.0.

Any help would be appreciated.

Don’t have access to pics atm,

10s battery battery support 10s 60a bms Vesc is diy and was sold to me by @ekitesurfer and was repaired by @JohnnyMeduse

Post your setup

1 Like

Do you have a link to your voltmeter? If it is a 3 wire meter I think you have it wrongly wired. If 2 wire I think its not working properly. Anyway I think this has nothing to do with the vesc issue. Unless some kind of power mistake damaged both

This happens every time you connect the vesc to computer or just the first time

Everytime I press connect

Maybe incompatible firmware? What bldc tool are you using. And does your vesc have a boot loader?

If your volt meter read 0.0 it does mean that you don’t have power going to your VESC, can you post some picture ?

Do you have a Multimeter ?

yes (granted its old but it’ll work)

Is that a 3-wire voltmeter? Hard to tell from the picture

Yes, should the white be connected to something?

Yes… It’s not there for show :joy:

Many high voltage meters like yours require an auxiliary power source, usually 12-24V, to power the meter itself. One wire is meter power input (12V), one is the voltage reading (~42V), and one is ground

The easiest solution is to buy a 2-wire voltmeter. There are plenty available that can accept 10S voltage

Thanks for the info. I definitely didn’t put as much thought into it as I should have. Woops.

It’s all good. We’ve all been there. Just look for one with only two wires, like this: