I dun goofed today :( ESC dead need new one (EDIT: FIXED it... So happy)

It was raining today and I was gonna miss the last bus home. I had to ride it out in the rain. I had been preparing my board to be splash proof over the past week getting a waterproof box, filling up holes with water proofing filler etc but it failed me…

RIP my HK 150A Car ESC. The ESC still accepts power and there doesn’t seem to be burn marks on the PCB that I can find without desoldering the top PCB from the bottom, its just glitchy. Can’t throttle calibrate properly. Motors don’t initialize. etc

Was thinking of getting this: http://www.hobbywing.com/goods.php?id=354&filter_attr=5417.5599

Any one used this before?

I’ll be running these with my Benchwheel motors.

Are you sure it’s the esc and not the receiver?

I plugged my HKSS programming card into the ESC. Can’t get the menu’s up either.

Might be an idea to leave it somewhere nice and warm for a while? Could be damp still causing the glitches … its worth a shot before giving up with it?

I’ve already taken it apart and blow dried everything. I’m 100% sure everywhere is dry.

1 Like

I have the 6s 120a FVT esc in stock and ready to ship. Only $55 https://electric-skateboard.market/product/fvt-6s-120a-esc-sensored/

Been playing around with the HK ESC and now suddenly allows me to throttle calibrate. After calibration, turn it off and back on. It should start beeping and initializing with the motors but when I turn it back on it just sits quiet. Fan running, nothing happening. HKSS program card has no response either. Looks to me like its the ESC for sure. Not my RX.

I did it!

I found out what was wrong… After hours of diagnosing.

I noticed how when I turned the ESC on, it would always go straight into orange light (that’s usually calibrating light) It wouldn’t calibrate though even in the orange light unless i hit that reset button again. This lead me to some thinking. The reason why it wouldn’t arm the motors nor would the programming card display any menus was because the ESC was going into reset/throttle calibration mode everytime it turned on…

I realised that the ESC switch was obviously broken from water damage.

De-soldered the red, black and white wires from the switch and I hooked up the red and white wires to a new switch. Just an average small switch you can get from a local hardware store. I then isolated the black wire for future use. And everything works now!

However, if I ever were to perform throttle calibration again, all I need to do is to touch the black wire onto the other red and white wires.

1 Like

Good job ! Perseverance pays off.


Maybe you can find another 3-way switch to hook it up as before.