I might have "bricked" my esc. Help?

I just started building my first diy and wanted to program my dual fsesc6.6 to make sure everything. Being a noob in this category, I think I bricked the master side. It no longer lights up. At first I had two blue lights and two green lights. Now I only have one of the two green lights. I tried with ackmaniac esctool and with vesctool and I can’t seem to get it back to where it was working. Any help or actual experience with this problem would be highly appreciated. Before15590745065856116932150683119174 AfterIMG_20190529_000402383

1 Like

Unplug everything and check if there is a short between the 3.3V rail and ground. Probe on the SWD header. If not, then all you need is an ST link and to reflash the firmware. The firmware can be found on github, I’d recommend getting a nucleo-64 board from Arrow.com and using its embedded st-link.


Thanks for the advice. Just checked, no shorts so I guess I f’ed up XD I’m gonna look into a stlink on amazon as in Canada I’m getting screwed on shipping fees and delays. I was basically trying to figure out why it doesn’t want update to 60 hw and was stuck on 46

No problem.

Also, last time I checked, Arrow offers free international shipping.

VESC as SWD programmer: Flash BLE modules and fix bricked VESCs

not sure if it works with FSESC

He makes good videos but I got completely lost from the start. It felt like talking to my 8 month son and trying to understand his answers

I’m gonna receive this tomorrow https://www.amazon.ca/dp/B072K3Z3TL/ref=cm_sw_r_cp_apa_i_lNZ7CbAX634N3 Now its gonna be to figure out how to do it without screwing up even more :slight_smile:

@Flasher That’s not an ST-Link… you won’t be able to reprogam the MCU with that. (The boot pins on the MCU are not broken out, so you can’t use the UART DFU).

Does Arrow not offer free shipping to Canada?


For example, the top part of the board is an ST-Link, it’s about ~$11 and Arrow should have free shipping.

They might but I’m not willing to wait several weeks to receive it ( customs always take time) and I’m in contact with flipsky to see if it’s an easy fix or a send to them for a fix. Would this work instead? Screenshot_20190529-224514

I bought the one from arrow. Would you be able once I get it to help me out on how to use it? It seems to be a pretty extreme piece that could allow me to make more damage than actually help


1 Like

If it doesn’t work out with your st-link, you can swing by for help (i’m in mtl)

1 Like

I’d be more than happy to help. The second item from amazon you posted should work as well.

You will need some male to female jumper wires.

There’s only a small part at the top of the nucleo board that is needed.

I wasn’t able to cancel my first order as it’s already on the way to my house so I might as well see if it can serve me in any way and then I’ll send it back. Arrow estimates I’ll receive theirs on the 3rd of June. Doubt it but possible. @Blasto you’re prob on the FB mtl eskate page :slight_smile: look me up ti-marc

Hey I just got back from the post office. I am at a total loss with this thing…where do I plug and to what pin do I plug them in the escIMG_20190531_200020523 IMG_20190531_200027352 ?

Managed to get it to work but now my problem has changed. I can’t update the firmware on ack/vesc tool no matter what I do.it is stuck on 3.102. I tried updating to 3.103 on ack and to 3.57 on vesc and neither stayed even if it said success. Also my slave now has a blinking red light alongside the green one when booting up.

Perform a full chip erase. Then flash the firmware you want. Connect to VESC Tool et flash the bootloader through it.

Then try to upload a new FW through VESC Tool.

Did you program them with ST-link utility?

You need to program a vesc6 bootloader at flash address 0x80E0000.

If you need, I can upload a short video of me doing this for one of my FSESC 6.6.

That would be great :slight_smile:

I’m moving forward with the physical part of the build in the meanwhile15594171560367442095420154358223 15594171848301040376096583839583 15594172066748941821636531436316


make sure BOTH devices have power and the nucleoboard is plugged into the computer before connecting ANYTHING.

make sure that the bootloader is programmed at flash address 0x080E0000 or you WILL corrupt the firmware.

Please let me know if you have any questions.

1 Like