I'm having trouble updating firmware

I got the same issue, wont upgrade to 3.58… And im not able to make it work at 3.57 either :frowning:

1 Like

We should have a SWD PROG cable soon. I will check the stock on Monday. Another method is using the ST-Link V2 which can be found for cheap in online auctions. Just make sure to buy one stocked in your country, not coming from the other side of the planet.

I’ve got 3.58 loaded :slight_smile:

Ok this time the first thing I did was to turn the Volume up on my laptop so I can hear when the upload is done about 30 seconds to a minute after uploading then 10 seconds after lights stop flashing.

This is what I had to do.

I had to use a SWD cable 80mm x 3pin only. Use a older vesc tool 1.13. Connect . SWD prog. Connect. Vesc6. Upload Reboot (and pull out usb as it can still get power from it). Do the same to the other vesc. Reboot. Vesc tool 1.16. Connect . Firmware update . All. Wait for sound. then 10 seconds . Reboot. :slight_smile:


This how it works (minute 5:40 onwards):


Thanks for the fix. But for me I have to wait until new fw release I guess. I dont have any swd cable :confused:

I don’t think a new FW will do it. Go to a RC model shop and get some plugs. I had to solder the wires to make a SWD cable. You only need 3 wires/ 3pin plug. Even try some local RC clubs . Good luck

1 Like


1 Like

Thank you for the update. @trampa I am using a Dual FSESC4.20, would I need to use a ST-Link V2 to reprogram mine?

If it has two SWDs, you should be able to flash one side with the other. Their customer support should be able to help you.

1 Like

I took a 12s balancingwire and tore it apart. I hope Its going to work. Thanks for the advice!

First time touching the vesc, so im not rly sure about this :smiley: Its supposed to be connected to batteries when I plug it into the computer? Just one vesc to computer? And then find old vesctool? Fck I dont know what im doing. :frowning:

Eek Watch the video above And read my write up again.

The cable goes between the vesc’s SWD port. The 3 middle pins. clk to clk. Gnd to gnd and IO to IO Vesc power via your board batteries. Unplug everything else. Connect laptop with usb cable ( make sure the usb cable is a data cable. Some are power only) Watch the video again Good luck

1 Like

Do you have a link to Vesctool 1.13? Cant find it, only for android :frowning:

Edit: Fw updated! It did work on the new version of Vesc Tool, fyi :slight_smile:

Thanks a lot Gannet and Trampa. Rly appreciate it.

1 Like

Still no success for me. I have connected the SWD cable and no include firmware appears when I connect through the SWD menu. I am really at a loss as to what to do.

I had the same with vesc tool 1.16 I had to use vesc tool 1.13 to do the SWD program


@Gannet I owe you a carton, mate. That worked like a charm. Interestingly I tried 1.1 to no avail but version 1.3 rectified the issue. Thanks again! Shout out to @trampa too. I appreciate it fellas.

1 Like

[Using VESC tool 1.13, also tried 1.08; F/W 3.57 down graded from 3.58]

Tried this per the video by Ben. Failed. So have power to both VESC’s (two Flipsky Dual 6.6), right? Check. ok, USB data cable is plugged in and connected to main “good” VESC that I’m flashing from, I place the VESC tool in SWD mode by clicking on the tab to the left of the screen. Then connected the SWD cable to my good VESC, then connected SWD cable to other dual VESC. There are no light’s like you see on Ben’s VESC (Don’t know why I don’t have them, I thought he was flashing a 6 also…?). I then click connect on the right side of the SWD screen but nothing happens like what happens on Ben’s screen. I got nothing. And I’m very frustrated. Ever since I upgraded to 3.58 firmware nothing but MAJOR issues with this POS. Even after rolling back and using an older tool.

Can anybody see what I did wrong?