I'm having trouble updating firmware

I have two vesc 6 plus units on a trampa holy pro. Twin 154Kv motors. 2x 6s 25c 10Ah lipo (12s 10Ah). My problem is when I update the firmware from 3.57 to 3.58 it uploads. I wait for the lights to stop flashing and some , reboot and the vesc still has the old firmware 3.57 I’m using my laptop with vesc tool 1.16 I tried to do it with my phone app and get the same thing. I’m a newbie at this and not great with computers or programming 20190714_102147 20190710_153838 Thanks for any help in advance, I’m going crazy here

I am having exactly the same problem and I have read that people other than yourself are too. When I updated to the 3.58 it reverts to 3.57. Also I can’t get on to the VESC website, it appears to be down at the moment.

1 Like

Cheers for putting me out of my misery, no boarding today then :frowning: Does anyone know how these feet things work, is it still one foot in front of the other ?

1 Like

No problem! Let me know if you have any developments, I will do the same. Cheers, Luke.

1 Like

Same problem. 3.57 at the moment. Also after updating - seems to write new firmware - but after reconnect its still 3.57. … I tried everything except USB connection. Only Bluetooth via Android app and PC VESC tool over TCP bridge.

I’ve been trying to get on the website. It’s been 3 days since I have tried. I have the download file, but it wont work because its copied and I think you have to download from the website for another device. Is this being fixed because I need to change my board settings?:disappointed_relieved::disappointed_relieved::sleepy::sleepy::cry:

Glad I’m not the only one having those issues. I was pulling my hair out I was getting so frustrated with it. Still, not very comforting to not have a fully functioning VESC tool.

I got my setup to the point I could ride it but I’m FOC in PPM mode and don’t know if the two are related but my motors shudder horribly if I am not already pushing to max foot speed before hitting the throttle on the remote. I get this rapid pushing/pulling on the belts and it tears all the way through the whole board…Wish there was a setting to fix that issue

I’ve had some success, I opened a old vesc tool on my tablet, 1.13 and reloaded the firmware 3.57 (yes not 3.58) My board is running again, I’m calling it a win :sunglasses:

Hopefully the vesc project web site comes back online soon!

The phone app won’t work as it wants new firmware and the board has only got half power (that is most likely me not knowing how set the vesc properly) but that’s enough for a well needed ride :smiley:

If the update doesn’t work, you should try and re-upload the bootloader. The bootloader upload is the TAB next to the Firmware upload. After uploading the bootloader, upload the new FW. Only do one VESC to try! If it works, do the other VESC.

The vesc server is down for a technical reason. Benjamin is still in France, after visiting the esk8 event. He’s back on the 22. July and will fix the server connection.

1 Like

Just tried the bootloader reboot then firmware 3.58 update reboot and 3.57 is still loaded. It was worth a try :frowning:

Stange! Can you run the SWD Prog feature? This allows you to use one VESC to program another VESC. Both VESCs need to be interconnected via their SWD Ports. IO to IO, CLK to CLK and GND to GND. No other pins are connected. Power both VESCs, run SWD Prog in VESC tool desktop, click on connect, select VESC 6, hit upload. Now one VESC flashes the other VESC with the latest FW.

FYI: VESC website is back online. I haven’t had a chance to try the firmware update yet. I will let you know how I go when I get home.

1 Like

I just retried it since the website is back online and still no cigar. Not sure what we are doing wrong but it keeps reverting to 3.57.

I don’t have a SWD cable. Don’t know how flashing one vesc to the other is going to help if both separately won’t update FW. I open to trying it tho.

Bugger, does your board run still on 3.57? My still works but I had to use vesc tool 1.13 to upload 3.57 which makes my board work. If I use 1.15 or 1.16 to upload 3.58 my will only run slow / 10kmh max speed.

Unfortunately, no. It’s a brand new build so it’s never been operational before. Is there anyway I could get my hands on an older version of the software to configure the motors? Or will it still continue to search for firmware version 3.58?

I tried it also today again. Same issue. Still on 3.57. Also uploading bootloader again does nothing. I mean, it seams it does something, Signal LED on Focbox and Metr.Pro blinks also like it’s tranferring data, but after that process, it’s still the same. Updating seems not to work.

Now I am thinking it is not a thing of VESC-Tool or Vedder’s website, because I tried also the Ackmaniac ESC Tool, and wanted to upload Ackmaniac firmware. Therefore I opened my enclosure and connected via USB. Bluetooth was not successful before, so I tried it with cable.

Result: The same. Still 3.57, not the 3.103 or something from Ackmaniac. Same procedure. It seems to write after pressing the upload button, but after restart/reconnect both VESCs are still running with 3.57.

So… IMO I tired everything. And because also uploading Ackmaniac firmware does not work, it has nothing to do with VESC-Tool, Benjamin’s server or vesc-project.com. … Ackmaniac is a different software, from a different guy on a differnt server. It HAS TO work. But it doesn’t. Seems like 3.57 cannot be overwritten or something. Maybe the files are read-only and you have to be Admin to overwrite lol. Idk. … Does everybody in this forum has this problem at the moment? Is anybody with 3.57 able to update right now? That would be interessting.

The entire software needs to be re-written via SWD port. I will help you to get this sorted. Drop me a PM.

You mean that SWD method you described above? That one VESC programs the other? Like @Gannet said, I also don’t understand how that should work. I have two VESCs and I am not able to update one of them. So, as you said @trampa , the software needs to be re-written. But both VESCs are running fw 3.57, which needs to be re-written, if you are right. Why should it work?

I can try this and I appreciate your help but I don’t get the point. A small explanation would be nice. Just what happens in that process. I want to know the background, I want to learn and understand. At the moment, for me, it makes no sense.

1 Like

OK, watched a video where Benjamin is explaining SWD prog.

I think I got it. As I wrote the last post above, I thought - because firmware update is not possible - connecting both VESCs cannot do nothing, because both VESCs need new firmware.

But after watching this video I think I got it. Because USB connection is there you get the original firmware to your VESCs. It’s all about the SWD port on the VESC, because it’s only working over this port.

OK, then I need a cable, because I don’t want to cut mine :slight_smile:

Thanks, @trampa