Issue with Carvon v2.5 motor


I’ve been riding this build for almost 2 years with no problems at all (Carvon v2.5 dual hub motors, space cell pro 3, nanoX)

Just lately, while I was carving, I noticed that one of my wheels sort of stopped. At first it didn’t call my attention as I could continue riding, but the other day the motor completely stopped and threw me off my board while I was riding.

When I picked up the board to see what was going on and tried to make the wheels spin, the motor was stuck and I could see a big spark.

When I got home and tried it again, the wheel spined just fine.

I made a deeper inspection and I could noticed that there is a break in the outer part of the motor. image image image image

Could this be the cause? Any ideas on how it could be fix?

Thank you very much for your help!

Hi there, connect to us via Live Chat at We’ll help you sort this out.


wtf, @LEVer out of nowhere?


Well they sure have taken a beating.

I’d say yes that would be a broken motor. It held for that long which is nice. I suppose you have never taken them apart before huh?

Yeah I’m surprised too.

There was a mention somewhere that a new team was getting back together to sort out their mess.