Jerky start off fix?

Any one know what I have to tweet in BLDC to get the take off to be smooth and not jerky from a stand still


Are those sensored motors? If you don’t have a vesc that can safely run FOC give sensored BLDC a try and will remove the start up jerk. The VESC motor wizard makes this easy to setup. Otherwise just give a single push before you apply throttle in BLDC mode.

1 Like

Push lightly before presding throttle / get sensored motors / buy a sensor kit

1 Like

Yeah I have sensored motors and using focbox mode… I do give a push off currently but id like to be able to have a smooth take off from stand still if possible

Thanks! they are sensored and am using focbox mode

Did u run hall sensor detection during set up? Could be real jerky like that cuz the vesc doesnt actually know which hall sensor is where… Once u push it understands but a stand still it doesnt. After sensor detection it should be smooth.

Yup ran all that stuff… it’s fine after I give it a kick push… was just hoping to be able to take off from stand still smooth too

Weird then… I have the same sealed 6355s from maytech and I get a smooth start fpr a stop … although I rarely ever start standing at a stop after accidentally busting my ass… Maybe theres something off in ppm settings

… Or maybe double check the halls sensors values got written to the vesc just in case…

Your sensors are not configured right. Either detection failed or they are disabled. I run sensor less and that’s exactly what it looks like.

1 Like

first, it’s not focbox mode, it’s just FOC mode


  1. in foc tab, make sure it’s in hall mode, and go ahead do motor detect and calculate, etc
  2. do hall sensor detection
  3. apply
  4. write back to esc


if that doesn’t work your motor sensors may be shot


I know its simple but did you write config/apply settings after the motor detection? If you have a sensor down it will tell you.

Oh I did the calibration before but I had sensorless ticked I THINK

Having the same problem with my unity. Solution?

Make sure its in FOC mode. Make sure you have it in sensored mode Make sure the sensor detection actually worked Make sure you saved your setting