Killed my VESC 😭

I plugged in a Bluetooth module onto the my vesc UART. Everything was working even the app was working for a moment, then the vesc stopped working. Any reason why ? The lights blue on the vesc, controller doesn’t respond, Vesc tool don’t detect it even my laptop doesn’t even pick up anything when I plug it up and tried switching micro USB cables. Nothing :sob: Has anyone had this problem before ?

Using: DIY VESC Bluetooth module from MiamiEletric Eskate app

This can be tricky. Blue LED only means there is 3.3V, but the MCU might be the culprit.

Notice anything burnt or shorted? Photos?

Do you have an ST-Link?

1 Like

Posted better pictures No burns or shorts that I notice. Don’t have a ST-Link. If I had one wouldnt it not work since the PC not detecting the VESC ?

An ST-Link connects to the MCU’s programming ports, so you can check whether the MCU is running or not.

1 Like

Could you tell me which st-link I need, there seems to be so many of them

Any of them would work, but i would say get it on Ebay i paid 1 USD for mine took a week to arrive.

1 Like

Am I testing correct

Thanks. Probably still get from Amazon for the prime. Really trying to figure out what’s wrong with the vesc fast since this is my commute for work and home. Edit: just bought will receive on Tuesday

If this is time critical, you should send the VESC for repair or get a new one. If you’re not familiar with electronics, this might take a while.

Do you have a multimeter?

When it’s plugged in, do you feel any parts heating up? You should remove the shrink wrap for troubleshooting.

Don’t know nothing about electronic. I do have a multimeter, posted video and pictures up but doubt I’m using it correctly. As for the repair, I contacted the site but said I’ll get a email response back from 24-48 hours

1 Like

You can use the diode mode of the DMM to see if something is shorted, but you were poking the top of the capacitors, which are not where the leads are.

Once you get the ST-Link, hook it up like this:

You may need a JST-PH connector as well.

If you don’t have soldering experience and a component needs to be replaced, you should send it to one of the forum’s VESC repair techs.


Once I get the ST-Link I’ll try that out as for the JSTPH Connecter I believe it comes with one. I order the purple one in that Amazon link I posted

Are you sure? I don’t think it comes with a JST-PH connector.

1 Like

Just ordered now :blush: Thanks

C25 getting a reading

C33 getting a reading

It’s over now I killed the vesc was testing the gnd and the 5v and this spark happened :sob:

Sorry to see that. Stay strong, brother! :muscle::rabbit:

1 Like

Dude thats mental When I was testing my vesc i was just poking around without any worry man i wad lucky

I know how it feels when you fry this expensive piece of electronics

I basically hit myself with a sledge hammer in my head for like 50 times then I went to sell my body for a focbox


@Sebike thank you, I will be sending it to someone hopefully for repairs

@Acido, it was because I had it powered on. I also touch the capacitor just for a split sec (not on purpose) and a little sparked happened. I disconnected the vesc right away, then replug again to see if it was working (wrong move, this caused a bigger spark) and this what it ended up to be

I feel so lucky now, I got an focbox for 80 euros

1 Like