Losing Eboard control, 2.4ghz mini controller not responding correctly

Ok. What you need to do is put the bind plug in your receiver. Then turn on your board, then turn on your remote while pushing the bind button. When the light goes solid you are bound. Then rev up your board. While it is coasting to a stop, pull the bind plug. Now just turn everything off and then back on.

To test, throttle up your board and turn off your remote at the same time. If you’re board coasts your good

ok, i’ll try it, thank you.

There are 3 kinds of failsafe: Through the VESC, the RX, and one that you really, really don’t want. You need to figure out how the receiver responds when the TX disconnects.

If the RX goes into it’s own failsafe, you cannot configure a failsafe on the VESC, but rather you depend on what PPM value the RX outputs when the TX disconnects. This should the same value output when the motor is at an idle.

Now, if the RX doesn’t have fallback, it can do one of two things: Hold the current value indefinitely, or stop outputting a value. The former can be disastrous. Do NOT use an RX that holds the value. This will leave you full-throttle down the road with no control. Too many people get hurt due to controller failsafe malfunctions.

However, some receivers will just cut their output. In this case, it’s up to the VESC to detect the ‘no signal’ state on the PPM line and engage the failsafe state (set the motor to idle).

1 Like

I currently have ppm settings on (current, no reverse with brake), when i letgo the trigger on remote, it doesnt coast, the motor just stops sudenly, how can i make it coast?

How tight are your belts? Does it stop because of tension? or brakes?

Also, Did you turn off your remote to see what happens when your board loses signal?

The VESC should idle if the RX signal is at 1500µs. (assuming that your endpoints are 1000 and 2000)

When released, the remote’s signal value in BLDCTool should be: (upper+lower) / 2 You should tweak the endpoints to make sure that the center falls on this value, or tweak the deadband if all else fails.

Next, try THIS custom fork of the VESC firmware and its matching BLDC tool version. I say this because you can individually adjust the two endpoints, and the center. Then you can make sure that your remote is working properly. Especially if you do any modding, like the SPARKLE mod, or replacing any potentiometers, you’ll need to use really weird PPM settings where the center is not necessarily proportional.

1 Like

@Tampaesk8er, could you describe your new problem a bit further? Is it possible you simply bumped the trim pots on the GT2B?

I just resetted the vesc by reinstalling the firmware and everything is working properly. I use the 2.4ghz mini controller, not the GT2B.