MakerX Mini FOC Plus Firmware update

I am trying to set up a board with two MakerX Mini FOC Plus ESCs. I am running them connected with a can bus cable. I believe they have - Hardware: V 6.6

  • Firmware: V3.58. When I tried to update the firmware with the Vesc tool I didn’t know which hardware to go with so I went with 60 that looked closer than other choices. After I updated I went to run Motor wizard and it said I couldn’t with the current firmware. Then I tried bootloader update and that didn’t really help me. As you can tell I’m not very good with this part of the board set up. Please help.
1 Like

Can you share a screen shot of the problem?

This is the screen shot after I auto connect in vesc tool.

1 Like

and this is the screen shot after I try using motor setup wizzard. I already tried uploading the firmware to both vescs. I chose hardware 60 for the update.

1 Like

I had the same issue trying to update some torque 6 ESCs…

Apparently a common issue, idk I guess Benjamin is working on it.

Thanks for the info. I’m not 100% sure what hardware i am supposed to select in the Vesc Tool. I believe my ESC were based of 6.4 or 6.6. Do you think I am supposed to choose “60” under firmware update in the vesc tool. I am afraid of making the wrong selection and ruining my escs.

could try vari-esc to see if a different application resolves the problem.

if the problem persists then possible to assume its firmware/hardware issue.

1 Like

Thank you very much for taking the time help. I appreciate it. I apologize but I am not very competent when it comes to computers. I clicked on your variESC link above and saw the 3 groups: BLDC, variEsc Tool , and balance buddy. I assume i would follow variESC tool, but i’m a little lost after that. I’m in a little over my head.

Does anybody know which hardware selection I should choose when updating the firmware of the makerx mini foc plus? I have not had any luck contacting them. Thanks

here is link to windows,

yeah, at first glance GitHub is really confusing… especially if you have never seen or worked with it before. I guess you can think of it like a drobox, its just a bunch of files & folders and no obvious structure.

1 Like

Thanks for the help, I got the firmware to update. I just needed to be confident that the hardware version was “60”, I was afraid to pick the wrong one but i just went for it and it worked. I ran motor detection and one of the motors worked and the second motor failed detection but didn’t give an error code the motor just stuttered. I’m gonna try to get that fixed now. Thanks again.

1 Like

make sure the connectors are soldered on good. bad connection at motor can be a detection issue

Yes, the problem is the motor not the ESC because i switched the ESCs between the two motors and got the same result. If I cant figure out what is wrong with the motor I will just buy another 6374 149K then I should be up running. Hey onloop, thanks for your help, I appreciate you taking the time.

Well Mr ego blocked my helpful post. Gotta love the censorship

Thank you jgoFast, More knowledge is better than less. I’m going to do a little work on my motor today and see if I can figure out the issue. If I do i will let you guys know what I find.

So I got the motors to pass detection. I think the problem was too much flux left on the bullet connector, If you can believe that. I also took the bell off and cleaned quite a bit of metallic dust out. So it was either a dirty motor of too much flux.

Now i just got to figure how to get both motors to work over can bus on Vesc 6. I can only get one at a time to spin. I’ll be working on that now.

1 Like