Maytech vesc help Please

I’m having a slight issue with my (Maytech) vesc remote settings, ( 2.4 Ghz remote). When my board is connected to computer and I use the keyboard, the throttle and coasting works good. But when i use remote controller, the speed at max is slower and when i realease throttle, it slams the brakes. No coasting when throttle released on remote controller, I appreciate all the help from all you talented eboarders, thank you all.


Here are my current vesc settings.

Did you set the PPM min/max? First disable your control mode, then go to PPM tab and check the “display” box. Turn on your remote and throttle all the way down and look at the PWM value, then input that value in Min Pulse width, do the same thing with max pulse width at full throttle.

Then turn on your control mode and try again. Also, what control mode are you using? PID speed control and duty cycle will brake at neutral

1 Like

(current, no reverse with brake)

Heres my remote and PPM settings.

1.5 minimum is awfully high, did you follow the instructions I gave?

yes, what is PWM value and where do i find it?

It’s under the PPM section on the app configuration tab. Follow the instructions I gave above to find your values.

this is where im at right now.

PPM section, not ADC

oh, my bad.

Yea now check the “display” box and turn on your controller. Throttle all the way down and record the pulsewidth on the box to the right, and put that number for “minimum pulse width”. Do the same for “maximum pulsewidth” at full throttle.

i followed the instructions but my numbers arent changing when i hit throttle. I cant find where you tell me to record max number and min number, im so confused. im running firmware 2.18 just incase.

Check the box in the left circle, and check the PWM signal on the right circle

ok, min was 1.43

max was 1.8.

Yep so put those values in the appropriate boxes and write config. Then try your throttle again.

I did but still brakes when i release throttle to neutral. SMH, LoL.

You’ll have to adjust the trim on your remote. True neutral is the median between your min/max pulsewidth and if your neutral position doesn’t match true neutral, it’ll accelerate or brake at neutral. Try to adjust your trim to get min pulsewidth closer to 1.0 and max closer to 2.0 with neutral being 1.5

its working at these settings.

You lose a lot of throttle range if the green bar isn’t in the middle at neutral, keep that in mind.