Mini remote losing connection after riding for a while (SOLVED)

Hi guys,

so I’ve finished my first build 2 week ends ago and I’ve ridden it without issue for the whole weeks after that. I was riding it carefully because I didn’t have grip tape at first. Last week end I took some time to go buy and put some on. I also finalised the esc enclosure. My first 2 rides after that were fine.

Since then everytime I went with the board I’m experiencing disconnections with the input. As a precision, I noticed I bent the pins for the servo cable on one of my ESCs. I thought it was that so I changed my ESCs from slave to master and vice versa so that the damaged pins are on the slave and not connected to the mini receiver… Well that didn’t work. I tried pairing the remote again but that doesn’t seem to be the problem as they do pair, I only use the connection while I ride. Once it first disconnects it reconnects briefly but i can’t have a good connection ever again for this ride. Once I let the board rest for a few hours, I can ride for 2-10 minutes without issue and then it starts again…

This is very annoying. Any ideas what could be the source of this issue ?

Thanks for any help I’m desperate :wink:

So I’ve recreated this at home. Right after I turn it on:

-> No issue it’s throttling fin

After ~10/15 minutes

-> connectivity issue

change the battery on the remote.


I’ve thought about it but dismissed it as I charged them full the week end I finished the build and thought they would go at least a month considering that I’m not riding that much. Also every time I turn it on they whole system works for 5-10 minutes. I’ll try it though. Maybe it’s that simple :slight_smile: I mean at this point I’m open to any potential solution I feel I’ve tried everything

Ah. The mini remote does not like 1.2v rechargeables. Try fresh alkaline to see if it helps.

The led on the remote blinks when battery is low.


Both my mini remotes act up when they get low on charge. I probably charge weekly


God I really hope it’s that. I use these:

I rode it to work without disconnecting today… I’ve been on this “issue” for the past 5 days, unbuilt, rebuilt everything like 5 times. I had considered the remote batteries but my previous one lasted for 30 days without charging I assumed this was the same… Don’t overcomplicate things.

Well at least this thread may help someone in the future :slight_smile: Thanks for your help guys.