Motor Stalling under load

Hello I have assembled my first board and after setting everything up and testing with out load i reassembled the pulley, and the motor is stalling under almost any load i can hold the motor with my hand and go full throttle and it doesn’t have the power to slip my grip. It can barely move the board unless i go full throttle. Below are my vesc settings and i have played around with them a bit.

Are my settings bad or is it the motor? Everything is brand new from Torque Boards.

Part list is: 12s4p Li-Ion 190 kv 6374 Motor Torque Boards Vesc Torque Board motor mount and pulleys

@GrecoMan ( i think you mentioned you might be able to help)

I think you’re suffering from the same thing I had… and inferior built VESC… :frowning:

I sure hope not, did replacing the vesc help for you?

Yep. Got a new one, problem solved :thumbsup:

what vesc are you currently using now, and was your first one a torque boards as well?

No, apparently the first one was from Freerchobby. I’d never heard of it/them until after I’d bought it but it was second hand, bought from someone here on the forum.

There’s some info about it in this thread:

My new one was also second hand but originally from Scramboards

Do you see any sparks inside your motor while doing that? How long are your motor mount screws

Thanks for replying. No i do not see sparks while holding it or letting it run free, and the screws are 13.85mm long and came with the motor.

Hmm check your phase wired and make sure there all plugged in fully. If they are send a picture of the solder connections to the vesc @LordChaos

1 Like

I had my motor stall out on me while I was on it. It made a loud screeching sound and stopped dead. I could recreate it on the bench after too. I seeked the advice of a couple esk8 gurus. All I did was up the battery max from 50amps to 70amps and re run the ppm wizard on ackmaniacs firmware. It had been fine since. Though I am still cautious. It could be totally unrelated. I guess I’m watching a learning to see how people deal with different problems. No more screeching though after about 50km even if I try to make it struggle.

1 Like

@Grecoman there are premade male 5.5 bullet connectors and the fit snugly in,

But I believe you helped me figure it out, as when I went to make the video after I loosened the motor mount to move it and it stopped stalling under load, when I tighten it back down there were sparks 1 screw was entering the motor path so i filed it down and it seems to be working I can still stall it with my hand from still but it can push me just fine no when i stand on it. I hope this wont be an issue later on, but it got me going pretty fast, now i need to bolt ever thing down to give it a proper test run. It was a bit to fast actually for having everything only taped in place.

Im routering my deck today so the battery can fit snug with the enclosure ill send some pics and a video when its all done!

Thanks for your help!.

1 Like

I’m glad you got it figured out! You had it better than I did, all 4 of my screws were shorting the motor. After that it worked like a charm. It worked until I replaced it (not because of the shorting).

Damn, thank god for the forums because I think that’s what’s happening to me haha.