Motor won't spin, Bad detection results and overvoltage error

Hello, I recently got my vesc up and running after to replacing the microprocessor, the green LED turns on when I give it input from my Nunchuck, but it doesn’t spin the motor at all. When I have it in FOC it can read the R and L but the motor never jitters or anything after running tests, and when I give it input, it still doesn’t respond. So after FOC failed I tried running the motor in sensorless BLDC but it always spits “Bad Detection Result Received” back out at me. After that I ran faults in the terminal and I get FAULT_CODE_OVER_VOLTAGE, so I used my handy voltmeter to test the voltage at the motor leads and they are all just at a constant 42 volts (the power being put out by my power supply), even when I limit the voltage lower than that they still read the 42 volts. Does anyone know what this might be? I’m thinking it might be the DRV is dead too now.

What are your voltage cutoff settings ?

1 Like

Currently they are: Min input voltage: 8.00V Max input voltage 30V Battery cutoff start 10V Battery cutoff end 8.00V

This is my current motor page

Also these are the faults I’m getting:

Well there you have it. If your power supply is giving 42v but your max input voltage is set to 30v, you’re likely to get an overvoltage fault. You need to raise the high limit to above your battery voltage.


@trbt555 good looking out! I thought that the new VESC default setting was was higher than this. @shuey what firmware version are you using?

I had the exact same error today, glad I found this thread

@trbt555 @treenutter so I changed the voltages and stopped getting the overvoltage error, but it still wouldn’t work. So i took the board to an oscillioscope and the signal from the nunchuck was making it into the DRV but there were no signals leaving it, soooo as far as i can tell it’s a faulty DRV. I then replaced the DRV with another one, and tried running it with no luck again, and looking at it with the oscilloscope again, it was the same problem. I think it may be my motor which is causing these problems, so I’m going to have to go out and buy a new motor, hopefully once I have yet another new DRV in hand and a new motor I can get it working.

Does anyone have a sense of how much higher this setting should be? It obviously needs to be high enough to allow a buffer for short voltage spikes, but then if it’s too high it will fry the VESC.

@trbt555 between you, me, and a few others on this forum I feel like we should write a “Welcome to your VESC, here’s how to get started” sticky - there are so many parameters that get overlooked when first using it, and many can lead to a destroyed device or a streeted face (I’ve made every mistake I think!)

You can put it to 57V, no problem.

What pins are you measuring to conclude the DRV is at fault ? You may be drawing wrong conclusions.

@trbt555 I tested pins 34 through 47 looking for anything, but they none of them changed at all while i was adjusting the input from the nunchuck (which was definitely connected).

So the DRV is not driving the mosfets, but is it being driven by the mcu ?

Correct, signal is coming out of the MCU, and being received by the DRV, but the DRV is not driving the mosfets.

I had the same problem and it was fixed when i set it to 57 amps, but now when i push start it and move the remote it does this short brake every time i press it. Any Ideas?