Motors moving by themselves

I’m using a dual focbox 6374 setup. Running bldc 12s. Also using the photon advanced remote, but have used diy’s nano remote previously. Same problem.

if the vescs are on for 10 minutes or more, the motors start moving and jerking on their own. This can throw me off the board. They start moving really slowly at first, unnoticeable when riding. But then you notice it. I often ride around and notice the board acting a tiny bit weird. Then i jump off and pick it up, and the motors are going backwards and forwards, by themselves.

When the motors have started jerking on their own they just jerk more and more, they never stop. If i don’t cut the power they would eventually spin with full throttle, then go full throttle reverse etc, never stopping. It would ruin my vescs. As i said, they start real slow, only jittering until they start spinning. I have to reboot the system to get rid of it (yes i have to restart my eboard every 10 minutes when i ride)

I used Y split receiver setup before, now canbus, but the motors jerk independently, as always.

Any ideas?

Had the same issue with CAN bus and 2 separate receivers. Try to re-calibrate the remote/receiver through the vesc tool under PPM and see if it helps.

Interferences somewhow… Do you have a ferrite on your PWM cable (the one from the receiver to the ESC) ? Does your problem occur everywhere or just around a specific place ? Is your receiver really close from the phase wires (the ones going from motors to ESC) ? Check if your cable are not too close from each others (signal cable VS power cable)

Did you just finish this build or did it work well before and just start going weird ?

Any pictures from your enclosure layout to help us ?

Well I this build was “ridable” a year ago, but I haven’t been able to trust it because of weird problems like this. So it has been on pause for a long time. I gave up on it.

So yes I have had this problem since the beginning. i tried moving the receiver as far away as possible, but to no help. The board is still acting really weird, sometimes. The problem can happen anywhere.

BTW: using UART now

I though it was an interference from the battery or so but this issue happened only in one motor so I switched between the receivers and it happened again on the other motor. It happened inside and outside a carbon fiber enclosure. A calibration helped in my case though.

Well i just did a small test outside on my terrace. I throttled from standstill, then the board suddenly throttled by itself, continuing for a second even after i left go of the throttle stick.

I don’t understand how that could be fixed with a calibration.

This is exactly the kind of problems i have, which no one has answers for, it seems. The entire year i have had this board, i have not felt safe, even though i have had fun. Please help me make this skateboard with expensive worthless electronics on it work, so it could be usable.

Don’t worry and don’t be bumped this issue will be solved. That’s the fun of DIY :slight_smile:

First of all don’t ride the board like that. Second, What FW are you using?

I updated the vescs to the newest firmware last week, I can’t remember the version. 2.54?

2.54 is an old one, there’s 3.xx already.
Find out what version.

What is your enclosure made of?

Jumping in here. Sensor motors? 2 years ago this happened to me. It was either bad sensor cables or power wires. Also do yoj callibrate the nano remote every time.befor riding?

Vescs are 3.38. It was 2.54 before I updated. Dual foc boxes.

Well this project has been on pause for a really long time so all I’ve used to keep everything together is duct tape. I received a really nice enclosure from eboosted yesterday though, which I will mount soon.


1 Like

Yes I’m using sensors. I will try switch them off in vesc tool

It happened to me sensorless but try disconnecting the sensor cable from only one and see if only one of the motors is good now.

well no enclosure then that’s not the issue.

If you have access to the receiver while this happens, try moving the connector to it and see if it helps

You need to remove the jst connector from the vesc. It won’t help dissable them in bldc/vesc tool Then detect motors again as “sensorless”

I hope I didn’t miss it somehwhere. Using the ferrite ring is important to clean up the signals running through the receiver wires. Do you have it? Hopefully you can get this problem figured out.

Those enclosures look sweet btw :sunglasses:

someone mentioned above but make sure ppm is properly calibrated, your remote can go out of spec over time

at neutral throttle ppm signal should be 50%, at full throttle 100%, full brake 0%

I had this sort of thing happen about a year ago with a bad ppm cable. Have you checked that? Mine looked good but wasn’t in the end.

I’m not using PPM anymore. I’m using UART with the photon remote. I can’t figure out how to calibrate UART in vesc tool.

Then it’s issue with photon mostly, as VESC just takes value of duty cycle in UART mode. Maybe Photon calibration got bad or etc :wink:

@Namasaki wasn’t your 6355 board doing something similar a while back? Is it still twitching?