My board suddenly stop braking down a hill

I completely forgot! Then the problem might be your firmware. Try updating that to the newest version. Just search for firmware there is a thread where people put the newest bestesteset firmwares :smiley: try that hope it works for you :confused:

Could you link/take a pic of your remote?

Also did you configure min/max PPM on the PPM page of BLDC tool? if you didn’t and your PPM signal gets lower than the minimum on the tab, the VESC can cut out.

@Jinra I have this remote :

When i push my remote al the way down on the bench, the gui shows 1%, mid position is around 50 % and max 100 %

You want to make sure the actual PPM value (not %) is not lower than minimum PPM on BLDC. However, I would toss that remote immediately. It’s the cause of many an injury on the forum including myself. That is the winning v1 remote which is notoriously unreliable.


@Jinra I would blame the remote 100% for the failure under normal circumstances, hence why i have GT2B remote in the mail. But the “reset to default bug” got me thinking that something else is wrong ?

Just to throw a spanner in the works here, I have the benchwheel remote, which I’ve been having no problems with for about 8 months on my previous setup, everything the same except running 6s 5000mah 25c Lipos. Now I’m running 8s4p 80A Li-ions and I’ve had this issue maybe twice now.

If I’m going along, and then almost ‘slam’ on the brakes, it seems like the VESC powers down and I have zero control, and then I gain control again in a couple of seconds. Then if I’m gentile with the brakes, ie. apply gradually, it’s fine.

To add to this, sometimes (not always) when I’m accelerating hard, (maybe up a tiny bt of an incline), it will cut out too. Thrown me off my board a couple of times.

I think this may be a similar issue. My motor is rated at 60A but my battery can deliver 80A, does this have anything to do with it? Max motor in BLDC is set to 60A.

@darkkevind Cut off for a second going up a hill with almost full throttle, is something i also has tried. My amp motor max is set to 50amp in BLDC, but looking at the recording in the metr app afterwards, is only showing amp peak at 33amps… hmmmm

Interesting… :thinking:

Sounds like it’s rebooting, might be overcurrent from braking going over the absolute maximum

Absolute max being the default 130A you mean? or going over the motor min I gave it?

Do you have a UART module and app for it? You could try getting it to happen to see what fault code you encounter. I’m just guessing it might spike over the 130A absolute maximum, but I’m not sure.

I don’t :frowning:

How do I sort that out?

It’s tough because since it sounds like your VESC is rebooting the error code with flush and clear when that happens, you’ll only have a moment to see what error code it’s giving you.

1 Like

So things that i will try now to resolve my problems is.

  1. Change the Winning remote to GT2B remote, and do the sparkle “hack” case mod.
  2. Flash my VESC with the custom firmware from @Ackmaniac to se if this changes anything. Also to get a more natural throttle curve, without the “turbo boost” i have now.

You can also get the benchwheel or nano v2 remotes. Those have proven to be very reliable.

I could not find the benchweel including the RX (I`m from EU) and people seems to like the GT2B, so…

Just giving you additional options that don’t need to be modded :slight_smile: DIYES sells the nano v2 and ships to EU i believe.

You can’t actually get the benchwheel receiver now :frowning:

Weird, I’m sure they’ll have it up again eventually. Good thing I stocked up…

If any of you guys is interrested I use this APS remote and it is absolutely bulletproof… I had a bunch of other RC remotes and this one is the best! and it is in stock!