My VESC blew up and i dont know why

So I was just taking my board out for a casual ride like I have for a while, the board in question was nine months old and never had any major problems and I constantly check and maintained the board appropriately, then after a drv failure on my vesc I bought a new one a replaced it with a new one and after only a few rides I felt the motor fail so Iooked down and noticed fire coming from the back of the board where the phase wires come out and as you could imagine I was quite concerned, got home opened it up to find a fried vesc though thankfully the battery was fine and all voltages were even and high at 4.09 volts per cell, I am assuming this is because I have a BMS protecting through discharge, anyway here are the pics:

20190116_174912 20190116_174930 20190116_174926 20190116_174917

Any ideas @JohnnyMeduse ?


which vesc you had before, which is the burned one? to what you set your vesc max min values ?

1 Like

Ive been using turnigy VESC, and the burned one is also a turnigy, the settings were max bat 30 min bat -20 max motor 60 min motor -40, I don’t think it was my vesc settings because I have been using them for nearly 9 months with no issue.

jap looks good, but nothing we can know without that you tell us. how was it mount? was there an opportunity that water could come there somehow? or other things that could cause a short? maybe other cables close to it etc.

1 Like

That VESC is done and cannot be repaired


are you sure? :thinking: :mage: :thinking:


All my cables were moved out the way and all connections were heat shrinked, as far as water, I never leave the boards near water and I live in Townsville Aus so I don’t even know the concept of rain, so I was thinking maybe it was a manufacturing issue?

1 Like

I’d like to contradict you and say that “all things are possible” but that vesc really looks like someone set it on fire with lighter fluid then striked the vesc with a hammer and then teared the vesc with 2 pliers in a failed atempt to rip it in half.


“Beyond Economical Repair” would be the category



I’m really sorry but I do not have any Idea at all on what happen. I just suppose it could be one of the power cap that blew up short and the heatshrink cut fire :fire:

1 Like

Maybe with that heat shrink you used didn’t allow any/very little heat dissipation and it overheated

vesc are supposed to shutdown if their thermal limit is reached, the vesc is smart enough not to kill itself. and heat shrink should be rated up to 100c without combustion

With this much damage you will probably never know, a good effort though almost burned it right in half. You should get an award :trophy: for most radical vesc meltdown.


As others said if all is going to plan the software will prevent it from damaging itself, so something physically caused a short, a component came loose or road debris etc etc. Then BOOM! :boom:


Yeah i was pretty surprised myself as i have had drv errors before but this definitely took the cake.

Ive gotten water on my vesc and all i got were fault codes, and once dried out it worked fine but this is just insane.

I got one wet too and it blew the DRV, no other damage.

mine didn’t blow im lucky all i got were drv fault codes and it somewhat worked like sometimes it had power but than no power, i could literally see moisture on the vesc heat shrink because it was clear after i got home

usually esc of any kind dont work when its wet but once dried out it should be all fine.

It was something in this area Screenshot_2019-01-16-18-02-28 being that was the source of ignition. I’m willing to bet something came loose in that area and crossed with something. Can’t say if that’s normal wear or factory fault.

Glad youre good though. So did you get the whole ghost rider feeling with flames coming out the back?

1 Like

Coming up next “WTS: lightly used VESC, blown DRV but hardly used, great deal! $100USD”

1 Like

In the second image, the drv fet at the top of the image has circular mark on it. For my experience of screwing things up. That FET looks like it shit itself. maybe the phase output shorted somewhere, maybe on the PCB where they are soldered hence the small localised crispy area. were you running fuses or just the BMS?