Need HELP! Motor rotates too slow


I just start to build my electric state board, but I have a problem that the motor rotates too slow. I adjusted my motor configuration and setting hundreds of times still doesn’t work. Really need some help there.

This is the setting of my board. I get a Turnigy G160 Brushless Outrunner 245kv (160 Glow) from HobbyKing. Two ZIPPY Compact 5000mAh 3s 40c Lipo Pack in series. I also get an Enertion motor controller as my VESC.

This is mine motor configuration on BLDC tool. How can I get my motor work with the same components? Do I have to purchase more LiPo Battery to make it work?


first off, set your motor amps to 120. You never set motor amps less than battery amps. Guarantee for bad performance.

Please don’t set your motor amps to 120…

Did you run detection?

Have you tried it? Even if you don’t want to set it so high, It should be higher.

Look at the motor, it’s a small stator single. They’re going to burn out their motor at that setting.

I had a 5065 single running at just 60A motor and it was burning hot after a 1.5 mile incline.

1 Like

I run the detection, but it says detection failed.

Increasing the motor amp will only increase low end torque when duty cycle is low… Once he hits ~37% duty cycle, battery max would kick in (if he sets motor max to 120a). I’ve found battery max to be a much better way to control how much power the motors actually see.

Are you trying to do a motor detection, or have you already done that? If you are doing a motor detection, try taking the belt off.

I have tested VESC with lower voltage (5S) on a 245kv 6364 SK3, and the motor barely turned when I had the belt installed. Running on 8S the motor really showed some decent power. I’ve never had luck with VESC at low voltage like 6S, I suppose a higher kv might work better.

Post screen shots. Try using a higher eRPM or current during detection (up to 1200 erpm or 6A current)

Isnt the Voltage wrong? Input Min = 13 Input Max = 13

no that’s his battery cutoffs, which shouldn’t be interfering with it unless he’s perhaps using 3S.

@charlie17 you did make sure your batteries are in series and not parallel ya?

@charlie17 your input voltage is wrong! Change the battery cutoff start to 25.2V and battery cutoff end to 20.4V

He is using two 3s, and I am sure he is using it in series, 13 volt will not move the motor fast, 20V will move it much faster.

“Two ZIPPY Compact 5000mAh 3s 40c Lipo Pack in series.”

Well i mean the title of the post is “motor rotates too slow” so he could be using 3s on accident.

Correct cutoffs are not important for setup or detection, just needs to be lower than current working voltage.

well I ran my motors on 13 volts, they did not move fast, he is limiting the max voltage to 13.

That’s the point, his problem is that they’re moving slow. If he put his batteries in parallel on accident, it would explain that since it’d be below the cutoffs.

No I am talking about he has his Battery Cutoff start to 13V! If he change it to 25.2V it moves much faster.

No… it doesn’t. Cutoff is the voltage floor for which the power gets reduced. He could set it to 0v and it wouldn’t make any difference as long as he’s actually using 6s.

Once you get “battery cutoff start” power is reduced a bit. Once you hit “battery cutoff end” power is reduced almost completely.

That value is not max input voltage, max input voltage is above that and is correctly set to 57v