Need help with vesc, first build plz help!

Im having a problem with my vesc, its from torque boards. ok so i wired up everything before putting it in my enclosure to make sure it worked. the blue light turned on and the vesc powered up and the remote connected and it worked. Now the blue light doesnt turn on and it gets really hot at the mini usb port. The remote receiver still connects to the vesc and powers on so idk whats going on. i talked to dexter at torque boards and he told me to update the firmware and he thinks its a bug but i can not get the vesc to connect to any tool and ive tried multiple cables. if someone can help me it would be a life saver.

My build parts. 10s3p samsung 30q, vruzend battery connectors. vruzend bms flipsky antispark and power on torque boards 4.12 vesc flipsky vx1 remote torque boards 6374 motor

plz help i couldnt get any from torqueboards

IMG_20190522_054728 IMG_20190522_054733 IMG_20190522_054741 IMG_20190524_165101 IMG_20190524_165223

before even touching the vesc, you need to take care of your battery. That thing is either going to catch fire or just stop working because all the wires will rub and jumble and be a not fun time.

You should take some electrical tape/fishpaper and kapton tape, and make everything is nice and neat, no over lapping balance wires, secluding connections from one another, not resting the bms directly on the cells, and probably other things

also, is that HM10 module powered by the battery? They function just fine off the 5v from the VESC, you can get rid of that connection and simplify your wiring a bit. Its going to be annoying to have to make sure that the wires of the HM10 can stretch to reach the battery


1st of all, ur gonna kill yourself with that battery, also where’d you get the remote from? some remotes are only compatible with their esc?


I think thats the flipsky remote, should work fine… but that battery though o_O

also I find it hard to believe dexter or one of his ‘helps’(these helpers used to be mediocre at best, sorry but its the truth) didnt provide you with VESC instructions, they have them copy and pasteable :thinking:


@shupeste I’m not positive (haven’t tested) but I think one of the latest firmware is bricking the v4.12s. You can email us and we’ll send you more info.

1 Like

Ya i know the battery is a mess right now, i just was testing everything to make sure it worked. Im going to clean up all the balance wires and all the wiring and the battery pack. Yes to the module, i just didnt know where to wire it on the vesc

1 Like

Ok ill try and figure some more stuff out and ill email you guys. Thanks

Sorry if I sounded harsh, I just can’t let something that would either injure the rider or board fly without saying anything

Hopefully it won’t be long until you’re on the road