New version 2.1 - iOS eSkate VESC app for standard and ackmaniac FW

Thanks for the reply emmaanuel - I’ll double check the mail app, should be setup through my gmail.

As for beta i did not - where can i get it? Only using the the purchased app off the ios app store.

Thanks!

Yes if you use gmail app only it won’t send you the email. For the beta you can send me your email address by PM.

support added for VESC FW 3.66

Hi can you add support to the latest FW?(its HFI added in it and its super interesting to try it)

@emmaanuel because of my 2 SK3 motors (sensorless) I also wanted to know how HFI works. Therefore i tired the new VESC Tool with Firmware 4.x. I really have to say HFI is awesome, makes a bit noisy sounds when accelerating and braking but working really smooth for my setup!

We all have to thank you about your great service for your App and the new analyzing tool! Would be so nice if you could also add the new Firmware next time :slight_smile:

@w31x @artteth , support for firmware 4.00, 4.01 and 4.02 added. Enjoy

3 Likes

@emmaanuel thanks for updating!

unfortunately i have firmware version 4.2 on my ESC and at the VESC Tool page i get only the newest version.

Has anybody here a older version of the VESC Tool? Downgrading my controller to version 4.02 would be no problem for me.

Or @emmaanuel is it possible to add also version 4.2 at your app?!

vesc-tool 2.0 may not ship with the older firmware but it can install it if you get a copy.

Trampa explains in down in this thread on the replacement forum:

https://forum./t/upgraded-vesc-4-12-to-firmware-4-1-and-got-error-fault-code-abs-over-current/20849/14

@fessyfoo thanks for the link! It´s easy to downgrade to a older Firmwareversion but then the problem is always to modify the settings. Because with a older or newer VESC Tool Software than the Firmware it is not possible to change important parameters at the ESC. Therefore i always need the explizite VESC Tool Software which fits to the firmware. Maybe someone has a solution to this or where to download older VESC Tool versions?

i don´t know if Firmware version 4.02 is the same as 4.2 ? tried it with VESC Tool v.2.03 (which is the newest i think)

@emmaanuel i tired now different Firmware versions 3.68, 4.1 and 4.2 but unfortunately with eSkate VESC i always get a “version is not supported” warning. Which Software version of eSkate VESC did you upgrade - v2.3 or v2.4 ?

depends how old you’re trying to install.

Trampa explains it here. vesc-tool 2.x will let you set settings on older firmware. https://forum./t/vesc-tool-2-0-and-firmware-4-0-the-beginning-of-a-new-era-serious/18881

@w31x

On the vebber code repository the last version is called 4.02, so I think it’s the same has 4.2.

I fixed the app to support this version

2 Likes

@emmaanuel YES perfect, now it works!!

@fessyfoo with VESC Tool 2.03 and Firmware 3.68 I tried to get a working connection with my PPM remote but it didn’t work. Especially at the Welcome Wizard -> Setup Input. Got only a to old firmware warning and no options to adjust something. Tried it also directly to adjust the app data at General and PPM with no success - no connection!?

Therefore i thought all other parameters can´t be changed. But basically it would be awesome if there is no need for the spezial VESC Tool version to change something at the ESC!

1 Like

Support added for latest 5.00 and 5.01 Enjoy

1 Like

Support added for latest 5.02 Enjoy

2 Likes

Whats happened to the web site to open up the recorded data csv file with gps map and trends of the data. I noticed after a while of it not working it was back up for a while but now doesn’t appear to be working again. https://eskate.emmaanuel.com/VDLA/

i get the following

This XML file does not appear to have any style information associated with it. The document tree is shown below.

AccessDenied

Access Denied

R0T5D8TQ5E8N6ATB

fKCtfAl0NcyozdROG3uPw9kwkNXBxoBB1oLHtNUuO47t4ul5aHIcr3nuyZDitcfK4Dqq0cINcfw=

Hi @ricoghardforth , you are right. I’ve move to aws the website and I forgot to move this part. Which is not mine, but I’m hosting it until the author fix his server. I’ll fix that today

@ricoghardforth now you can use VESC DataLogAnalyzer I’ll fix the URL in the app very soon. Enjoy