New version 2.1 - iOS eSkate VESC app for standard and ackmaniac FW

Yep. At 9600. I’ll have this one on Monday. I can test it. Maybe one less you need to buy.

DSD TECH HM-10 Bluetooth 4.0 BLE iBeacon UART Module with 4PIN Base Board for Arduino UNO R3 Mega 2560 Nano

Dang nice app! I bought it, installed and it works great just couldn’t get it to write the settings. Like some other people.

Are you also going to make it open source? I would like to learn how it works and play around with it.

Thanks for that. I’m working on some improvement for those module who are a bit to slow to push the configuration to the VESC, within the FW timeout.

Any updates on VESC6 / 3.xx support?

The next update will be compatible 3.x Available very soon.

1 Like

I’ve never tried, but @Mickyboy and @JohnnyMeduse are using the app with hub motor. With hub motor, you have to select 1 on both teeth number (motor and wheel) setup to get an accurate speed.

i can confirm that it was the Bluetooth module preventing the writing to the vesc for me

This one is confirmed working:

DSD TECH HM-10 Bluetooth 4.0 BLE iBeacon UART Module with 4PIN Base Board for Arduino UNO R3 Mega 2560 Nano

Great news ! Thanks. On my side, I’ve been working on the timeout problem. The new version of the VESC FW (3.29 or greater) fix definitely the upload problem seen on some lazy Bluetooth module (thanks to @rpasichnyk for that)

I’ve publish the next version of the app in beta test, if someone want to test it, just send my your email by MP.

1 Like

Any way to change units to mph? I’m American haha

Check settings (last tab)

i cant find it, last tab only has email info any thats it :frowning:

@Pimousse has join the beta program, so he’s using the new beta version. This feature has been added to the app, and will be available for everyone shortly.

If someone else want to join the beta program, just send my your email by MP.

I’ve push a new version of the app (v2.0). The first post has been updated with details. Feedbacks are welcome !



Nice Update! had some things going on otherwise would have loved to help test beta

1 Like

Great. Can you send me your email in MP ?

Hi, does this app work with Ackmaniac’s new extended firmware based on the new VESC Tool? -

Hi RiGo,

The app is compatible with standard VESC firmware (v2.18 and 3.27, 3.28 and the latest : 3.29) and Ackmaniac firmware(v2.53 and v2.54). But at this moment the app is not compatible with the new @Ackmaniac fork based on 3.x version, because it’s too hard to follow changes he is doing. I hope he will use GitHub like the others to make it easier and add back support to his great job. If this change, I’ll update the compatible version list in the 1st post.

Thanks. I love the fact that your app works on iOS. I’m having a couple of problems though. I’m not able to write settings to the VESC as others have mentioned. Also, I’m not receiving emails with the log file. Is here another way to view/retrieve it?

Welcome Rigo, For the writing problem, you can upgrade the last offical VESC FW 3.29.

For your email problem, the app use the internal phone email system. Is your iphone setup to send email ? Did you fill the settings in the app to activate this function ?

Thanks Emmaanuel. I solved the email problem but now I’m running Ackmaniac’s firmware. I hope that you’ll support it at some point soon!