Noob Needing Help Connecting BLDC to New VESC

I am officially new to this eSkateboard thing. Having issues connecting VESC to both Mac and Windows XP machines (it’s old).

Bought the Buffalo Dual Motor on Kickstarter and actually received it - believe it was manufactured by if anyone cares. Used it for less than 8 hours and went through one battery (replaced by Buffalo) and burned up the ESC while braking.

So rather than get another crappy ESC, I bought 2 VESCs (Vedder) and a bunch of supporting cables from . Including the programming USB cable.

I installed BLDC tool on Mac & Windows (XP) and can’t get the BLDC to see the VESC. I have connected the VESC to power and getting solid blue and green lights, and red blinking light (2 flashes)

I have searched this board and the web and have tried all sort of things but VESC is not appearing as an option to connect with

Any ideas are appreciated.

You’ve clicked in connect in the BLDC tool? Choose the right port? It should work fine, but I don’t know what is going on, can you put some pics?

Try updating drivers as described here:

See the attached on the drop down. It is the same pick list for both Mac and Windows XP. And I have added a pic of my USB Hardware showing from my system report. Assume it has to be driver issue but I am running OS X Sierra and can’t find one for it.

I have already tried the drivers. Interestingly, when I add the card to Windows XP, it is showing up as a Universal Serial Bus, and a Virtual Com port. Most likely the issue. I found a virtual COM Port Driver from ST Micros site, but it doesn’t work. Was found here -

Possible my Windows computers are just too old.

I figured it out and was a total Noob error. After many hours of trying with multiple laptops and driver installs, it was as simple as me using the programming cable (STM32) to connect to the VESC vs. using the Micro-USB cable. I thought the programming cable was required to configure. BLDC-Tool working on Mac OS Sierra and have already started to configure my motors. Thanks for your help.


I don’t understand why you have to connect your VESC to your computer ? :s

This was for the BLDC-tool so I can configure the VESC for my specific motors and preferences. It has to be done in order to operate the board.

Does I have to do it too ?

Being new to this I am not sure you have to do this in all cases. But my assumption is that every motor is different and the VESC needs to be configured to support each one. There are a lot of videos out there to help that I have found on this forum, and also on the internet. A couple below:

Basic Configuration -

Setting up FOC -

And I did get the software/configuration working for my motor using the instructions. Quite easy once the computer connected to the VESC.

1 Like

thank you !

I am having the same issue on my macbook where it isnt connecting. You said it is a programming cable issue? I have the flipsky dual vesc6.6 and it came with a little usb cable. Am I missing something?