Not getting 100% power

hi! so i finally finished my first eboard assmble, and i tried it for the first time today. so first it was awesome and worked great, but then after a few breaks suddenly the motor didnt spin as fast as it was before, and break system wasnt very strong either. after unplugging my xt90s loop key and then connecting it again, it came back to life and i had to control the beast again. what did i do wrong ?

p.s. i noticed that my motor mount screws was very loose - i dont know if its related.

First off, what is your setup up?

R spec 6355 6s lipo 8Ah Vesc Gt2b

make sure all your screws are tight first! locktite!

6s is pretty low voltage for vesc, could be over current or over heat. 8s, 10s, 12s is really the way to go with vesc.

post your config settings and i’m sure someone will spot the issue.

Post motor page from BLDC tool. It’s probably the voltage cut off value.

Could be your wiring/soldering. So many possibilities!

Also, who made the VESC?

i bought the vesc from enertion, and ill be uploading the bldc motor page soon.