One motor will stop working occasionally

So I have a duel setup, Focbox’s, slave connected over can-bus. Configured using BLDC TOOL, firmware 2.18. One motor will stop working when the remote is not used. Sometimes in a matter of seconds and sometimes it will take several minutes of not using the remote before it stops working. It’s the Slave Focbox. And the Focbox doesn’t actually shut off when this happens. I made a video I’ll try and post right now. Thanks. Oh, and it worked fine for a whole day on one particular ride. But then today it now keeps shutting off. Any ideas?

Here are pictures of the app config.



Same thing happens to me, interested in this thread. Which remote are you using?

I’m using a Photon, btw.

Cheers, Ricardo

Im using the nano V2

I think I got it! You still there ?

yeah! So how did you solve it?

So the Focboxes where confused as to which one is suppose to pickup the signal… I had both Focboxes controller ID set to 0, and both set to “current no reverse with brakes”… so they where both trying to pick up a signal.

So here’s what fixed it. Make sure the master Focbox , the one plugged into your receiver, make sure that one , in the app configuration, general tab, the controller iD is 0 Then in the slave Focbox , make sure the controller id is 1 And then also in the slave settings, app configuration, ppm tab, hit disabled. (if your remote is a ppm remote)
Then write configuration and celebrate like I did :grin:

This way only the master (the one named 0 ) is the only one trying to pick up a signal and then sending that info via can-bus to the slave.

My motors work fine now. THANK YOU TEDDY TOBOGGAN!


I was also told to UNcheck the box “send status over can” inside the master ESC. Then inside the slave ESC select UART only.

I did both of these things as well as the other stuff previously mentioned and everything seems to be working perfect.