Problem with controlling motors via remote

I’ve recently finished building my first esk8 and wanted to program the VESC (I’m using UBOX from Spintend, two Flipsky 6374 motors and Flipsky vx2 remote). I was following the steps covered in this video:

The motors were working fine for a small while…didn’t take it for a ride though but now when I press the trigger on the remote the motors do some weird sounds and don’t move at all as if they were simultaneously trying to go both directions forward and backwards. And when the command is given via PC or mobile app VESC they work normally. Please does anyone has a solution to this? Thank you very much! :grinning:

PS: I can give more information on my build further if it’s necessary

1 Like

Are they hall sensored or not? This basically will be the answer. And does this happen when you flip the board on the deck (or back side) and press the trigger to see if it moves? If it moves fine on the deck side but struggles to move with your weight on it (flipping it on to the wheels), try kick pushing it. If it works, the hall sensors are broken and you have to kick push.

Thank you for your reply, Yes they are sensored and it even happens with no weight on the board or when I flip it on the deck. Kick pushing doesn’t help too unfortunately. I also tried running the motors sensorless but with the same result.

I’ve recorded a short video of what it sound like. It’s in the zip file attached. (3.2 MB)

Hope you can figure something out :smiley:

Oh wow. This is the third ubox issue I’ve seen. If you can give a few details on the set up like:

Was this done in FOC mode?

Are you using PPM? Or UART for the remote control? Or both?

And did these motors move when you did the set up?

I heard that these came with their own remote. But im not 100% if this is the case.

But yeah, these ubox issues are quite similar.

Sure, The setup was done defaultly in the VESC tool program and I think it’s FOC mode by default.

I’m using a UART controller which should work properly.

When setting up the motors, they move normally and even if I want to invert the current because the motors go forward in the opposite direction, click on the forward button to determine which way they spin, it all seems normal.

The only problem is controlling them with the controller. I’m not using theirs though because I already had one from Flipsky

It also worked normally like a day or two ago…

Have you tried checking the remote setup to see if the remote didn’t randomly gain issues? If this has already been done, unfortunately this would be on the manufacturer since at this point, it might have been damaged by something. I rarely seen this issue and its actually very few who has this issue.

Sorry if this doesn’t solve the issue. Its a super rare issue that isn’t constantly spoken about.

Well I checked the remote whether the problem wasn’t there however can’t find anything. So do you think the problem could be solved by buying a controller from Spintend which they claim is compatible with the UBOX? For example this one:

That might be your only option if the remote doesn’t work. However, i would like to see how you connected your remote on the ubox. If you can show this photo, I can think of a solution. Hopefully, you dont need to; and I would like to avoid that if there can be a solution.

Some people had issues, even with the original remote. You’re better off with a different esc tbh.

Oh my…I really don’t want to spend a fortune on another esc. To be honest it’s my second already because I fried the first one from Flipsky XD. So I think contacting the manufacturer of UBOX should do the trick so that they tell me what’s wrong perhaps… thank you for your time anyway :smiley:

1 Like