Problem with HM-10 and UART

Hey fellow esk8er,

I recently bought an HM-10 that I want to use with @Ackmaniac APP to display realtime info but I cannot get it to work. My status is: Phone with ESC Monitor is connected to the HM-10 Module, but no info is shown. Set Baudtrate to 9600 and PPM+UART and crossed TX and RX from HM-10 to VESC. I used following pins of the 7 pin JST: x-TX-RX-x-GND-x-5V I use a chinese copy of the HM-10 but since I can connect my phone to it, it doesn’t seem to be the problem.

Thanks for helping :slight_smile:

Did you reverse the order of rx and tx pins

tried both but still no data (APP claims: “ESC not connected” when i try to read faults)

Which android version? Some experienced problems on OREO i think. Are you sure you have UART+PPM enabled in vesc tool?

Have you installed ackmaniacs firmware?

Real time data should work without Ackmaniac firmware, right? I tested it with my Xiaomi which has Android 7.1 and the same Problem occurs :frowning:

Have you turned your board off since you changed vesc settings? I had the same problem and restarting my board seemed to fix it.

yes, restartet it multiple times :slight_smile: is there any way to check the uart connection?

What firmware version are you running on your ESC?

1 Like

4.30 , the newest one I think :slight_smile: edit: misstyped should be 3.40

3.40? If so, BV made a change that breaks these apps. Options: downgrade if you have an older version of VESC Tool available, or wait until ackmaniac updates the app.


does your bt module show up as BT05 when the app is scanning for devices?

mine does too, it just doesn’t want to work.

this person changed baud rates and seems to be working.

1 Like

@thisguyhere Just as clarification - I have the bluetooth module (not the pro one). And it is recommended to have this running at 115200 bauds… but good luck for all the other people getting theirs to work

flashed the ackmaniac firmware, now it works flawlessly, big thanks to @AutoItKing