Programming vesc via Bluetooth port?

I know this can be done via Bluetooth directly like the trampa bt module but is there anyway to connect it to my pc from that port? My USB port broke and it took one of the solder pads with it so it’s going to be near impossible for me to fix and finding an expert to fix costs way too much. Thanks

You can also get USB - UART module and just plug tx/rx and ground and program it

Ok thanks!

Only rx , tx, and ground need to be plugged in? What about 5v?

5V is needed if you need to supply voltage to the device for e.g. bluetooth, but as your USB-Uart runs from usb it doesn’t require power

1 Like

I just got the usb to yard thing and I’ve plugged in ground rx and tx but after messing around with the switches on the pcb the most I can get is the rx and txt lights to come on but not usb. This only happens when I accidentally plugged ground to 3v3 and no lights come on any other way

@Kug3lis it works on my Mac, all 3 lights on with only rx tx and gnd plugged , but still nothing shows on the tool,

what cable you got maybe you need drivers for it. Can you open terminal and write:

ls -l /dev/tty.*

imagethis is what it looks like now

@Kug3lis nothing appears on the terminal when I type it. Where can I find the drivers for it?

Can you open System Information and make screenshot of USB devices?


The last one usbmodem should appear in the tool under serial port list

@Kug3lis I’ve tried both MAC and windows and they both have the USB lights blinking now and I’ve installed the Drivers but still nothing under the serial connections

Can you show me your vesc tool screen under connection tab? with the list of port select box?

Because serial port is definitely opened I see it in terminal, maybe also try to swap TX/RX

tx to rx and rx to tx pins?

@Kug3lis I swapped rx and tx with same result … :frowning:image

imagebtw what do these 3 switches do?

To tell you the thruth I don’t know this adapter so can’t tell you much, but I think something is bad as RX/TX should only light then there is some traffic on signals. Maybe check your wires. Also what kind of dinosaur is your VESC Tool?

Haha I didn’t bother to download the new VESC tool yet. Does that mean this Focbox is fried ?