PSA; ackmaniac Bluetooth compatibility with the pixel 2 xl is extremely spotty

It actually connected fine with my old pixel 2 xl, but that one got stolen and I had to replace it a few weeks ago.

With my new one, the app -REFUSES- to communicate with my board. It’s seen in the list and tries to connect, but nothing happens and it eventually disconnects without any errors.

I’m using dual focboxes, as well as This particular adapter from bkb Which uses the hm10 module

Maybe its just this particular Pixel? If it worked on the old one it might be the quality of assembly, ive heard a lot of mixed feelings about the build quality and craftsmanship of the new gen Google phones

I’ve got a pixel and a pixel 2, both if my BKB BT modules connect to both phones with no issues. I think its likely your phone.

1 Like

Android 8.0 included some bluetooth security upgrades that broke compatibility with certain HM-05 and HM-10 modules that don’t pass whatever security checks are in. It’s likely your new phone had the newer version of Android and that’s what’s causing your issue. There’s plenty of threads here about which modules from which suppliers don’t have this security issue, and swapping your HM-10 will likely solve your issue.

@moderators can you close this? Feels to me like @Ackmaniac’s app is shamed for no reason. This is probably a clone module with wrong firmware.

Module from build kit boards, actually, he’s a good guy.

so? doesn’t mean the module couldn’t be a clone. The genuine ones are actually quite hard to source. I don’t blame him or you - just do the update procedure i posted in the app’s thread. If the problem persists we can continue trying to find a solution.

Try turning on your location, it doesnt work without it for me, im running lineage os that is probably the closest rom to the stock google one

Here’s a direct link to the update procedure, by the way

1 Like

Ugh, nevermind. Flashed the new firmware, thought it worked. Put it on my board aaaaand…

Same behavior.

alright i’m kicking this back to being the app or android’s fault i’ve gone through three different HM10s which all behave exactly the same, constant connect and disconnect cycle every few seconds with no data transmitted

one from BKB: which i actually flashed to the latest firmware using the instructions posted a few posts up, didn’t work

one from amazon: didn’t work

and finally one from Psychotiller: which i know for a fact is the real deal hm10

so what the heck is going on?

Your phone is broken as the app work for everybody else or you have some broken hm10 modules’s or your VESC is broken.