Sensored motors cogging and jittering - WHAT'S WRONG?

I’m really desperate because my system is not working properly. I run dual V4.12 with sensored 136kv trampa motors on my e-mtb but I have huge problems with cogging on startup. Even on concrete there is cogging but I can start from a dead stop (if it’s flat, uphill no way), on any other surface it is almost impossible to start, even on grass slightly downhill I can’t move from zero. That totally kills a lot of fun with this great trampa mountainboard and I really don’t know what this could be because I’ve tried everything possible I can imagine.

Any suggestions welcome, I think I need some experts!

What I’ve tried so far:

4 different V4.12 with no difference in cogging 2 different brands of sensored motors - same cogging Tested all 6 possible phase wire combinations - always same cogging Different length of phase wires and servo wires (3 different cables tested) several times checked all power cables, connectors and phase wire cables. Tried different remote control and receiver (who knows, but same as always)

more details: I run my dual V4.12 with FW 2.18 (tried FW 3.26 and FW 2.54, too - same cogging) in BLDC Mode (hybrid - traction control - slave via CAN bus). Tried different start up boost settings up to 0.1, motors get more punchy but still cogging. When going reverse same cogging, higher amp settings in BLDC Tool brought no results, too. There are no problems with motor and hall sensor table detection in BLDC Tool. The motor sensors are working, there is a difference compared to sensorless mode. I’ve also tried sensored mode but same cogging as always.

remaining setup info: 10s 10Ah Lipo Turnigy Graphene (150A discharge/50A charge) 200mm wheels, pulleys 15/66 HTD5M 15mm belts Anti spark switch Steez remote

Here a video of my cogging motors so you can see the annoying start up performance (plus test ride):

I didn’t change anything special beside startup boost in BLDC Tool. But who knows maybe you’ll discover a wrong setting or you know what to tweak. Here we go:

If someone has an idea what’s wrong, let me know, thanks!

Are you sure you wired the Hall sensors properly? Please show some pictures of the wiring. Try changing it to sensored. Make sure you do a motor detection without the belt. I’m no expert too hehe

I didn’t change the wiring, just soldered extensions (80 cm), but I’ve tried it with different lengths of extensions and also with no extension directly plugged to the V4.12. In BLDC tool the hall table automatically changes to my table when clicking APPLY after motor detection. But wouldn’t BLDC tool give me an error in case of wrong wiring?

And I tried sensored mode, no difference in cogging.

After clicking apply did you write the config? If not it wouldn’t have saved the values that you just detected

1 Like

Yes I clicked write config every time… also I compared the saved hall table after reading config with a further motor detection, it’s the same.

Not giving enough power could result in cogging(seems strange since its sensored), maybe adjust the minimum duty cycle?

Do you know a safe setting for minimum duty cycle to change? Don’t wanna fry my new V4.12 ( that’s my 5th and 6th V4.12 on this build within 2 weeks, the first 4 are faulty)

1 Like

Just FYI start up boost pretty much IS minimum duty cycle. Vedder recommends no higher than .15.

I know it’s pretty obvious, but you made sure to do separate hall sensor detections for each VESC/motor pair right?

4.12 are not the best at power delivery so you’ll probably overheat it quickly but have you tried raising your motor amps.

1 Like

@Jinra Ah, ok thanks! My highest start up boost setting was 0.1. The motors got more punchy after startup but same cogging.

Yes, I set up each V4.12 before connecting the CAN bus and make dual settings. Also I’ve tried the performance of single V4.12 with one motor, makes no cogging.

I did minimum 50 motor/hall sensor detections the last 2 weeks with six V4.12 (no joke). My first 2 flier 4.12 had broken hall sensor ports and temp sensors, I switched to maytech 4.12, one of them had broken hall sensor port, too (cold solder joint, could resolder) but maytech SUCKS!!! BAD BAD performance :sob: So I took my last money (I mean some future money :joy:) and bought 2 quality PCB’s 4.12 from @esk8 but unfortunately there is no difference in cogging (but in performance).

I know 4.12 are not best for MTB use but I have plenty of power with this setup if it’s not too steep in offroad conditions and I don’t start from standstill again :wink: My enclosure has holes for some air and I can ride for 1,5h without problems (full charge). My max mosfet temp was about 70 degrees (ok once 80 degrees), i’ll add heatsinks or thermal silicone in the future but this cogging kills me right now.

My highest max motor and batt amp settings were 60A (like trampa motor is rated). My battery is good for 150A cont. so I could try motor max 80A and batt max 70A and see if there is a difference (and if motors getting too hot)

I think a dual V4.12 must handle a startup without cogging (with sensored motors). Strange is that it’s exactly the same cogging in sensorless mode as in sensored or hybrid. But i can feel that the sensors are working in sensored/hybrid mode, there is a difference in performance but not in start from a standstill. Weird.

1 Like

Try raising the motor max amps. 50a motor max is really low. Raising the motor max will give you more power at low speed and when starting off. Find out what the max amp rating is for your motors and set it there. I run 80a motor max on my dual street boards

1 Like

The motors are rated for 60A max as far as I know. @trampa suggest not to go higher than 50A motor max. that’s why i set 50A but I’ll definitely try to raise it (60A made no difference). Can I harm the motors with higher max amp settings than the motor is rated for? But I think I won’t hit this amps in real life (when I trust my app)

I have tried running mine at 100a but that caused them to run hotter so I backed it down to 80a You can raise yours and then stop and check your motors to see if they are getting too hot. Note: if your riding in 100F weather, they are gonna be hot just because of the ambient temp.

What are the size and power specs on those motors?

6364 136kv 7 pole BLDC Motor 2400W Internal Magnetic Hall Sensors on Axle Shaft

These motors have HAL and Temp sensors so the Vesc should monitor the temp for you. I would raise it to 60a and see if that stops the cogging and if if gets better but not completely gone then I would start ticking it up 65,70,75 until the cogging stops. Then let the vesc monitor the heat.

In Vesc-Tool with FW 3.26 i can monitor the motor temp but in BLDC Tool and FW 2.18 not. I don’t really know why there is motor start end end temperature setting because as far as I know FW 2.18 can’t read motor temp. But I use my fingers as motor temp sensors :joy:

1 Like

I used this to check temp on my hub motors, Haven’t had to worry about heat on my belt drive motors.

If you extended the sensor wires, make sure the wires are in the right order. Often the motors come with a smaller plug on them and when requiring the correct plug into the sensor wires the colors do not match. This could very well be your issue.

I assumed they were in the right order given that detection actually works and the values look correct to me. However, I guess it’s worth checking.

@rich Keep in mind that most motors have a different order of sensor wires than the VESC takes.

After watching your video it sounds like the sensors may be working but just not properly from 100% stand still. There is that kind of gear noise when they first start to move, I get that from censored mode at low speed. My board does the same it will not start from 100% stand still but half a push and it will get moving. Its still much smoother than un-censored mode. Maybe try un-sensored mode to see if there is any difference, that will tell you if the censors are working.

If my boards is not loaded the wheels will always start from stand still and always in the correct direction, no jittering like un-censored. And the minimum rpm is lower than un-sensored.

As to how to fix the issue I don’t know, but I do think the guys saying start up torque too low are onto something.