[solved] I think :D - Unity problems..... Please help

I’m having insanly anoying problems with the Unity.

Please check out these 2 vids and I hope someone can help? My trampa worked perfectly with 2 normal focboxes and I’m trying to replace them with a Unity. But that just won’t work? Sensorless motors.



@Deodand @CarlCollins those are the right people to ask. :smile:

Did you program them and run through detection? or did you just try to plug and play? It’d be helpful if you included more information and what problems you’re having and what you’ve tried doing.

1 Like

Did you use PC or app to configure this?

Use the focbox tool program and up your Sensorless erpm to 5000 or so. That should solve your stuttering problem @SynteX

Other things to check Rerun detections Rerun sensor detections Make sure all bullets are plugged in

1 Like

This is my second esk8. I do exactly know how to program them

I’ve connected a: 30q 12s5p And got the following settings: 80A bat max Both motors 60A max

I’ll do some things @barajabali just said.

Let me try that.


Didnt solve the issue


Did you do what I said about changing the sensorless erpm?

Using the focbox tool?


10 char

1 Like

why would sensorless eRPM affect anything if he’s running sensorless to begin with. Assuming he correctly set the mode to run sensorless…

Like this?


no that’s openloop erpm. There’s a section in “hall sensors” for “sensorless eRPM” but you shouldn’t need to touch that if you set it to “sensorless” in the “general” tab.

Hahah than i won’t write these settings let me change that other setting :stuck_out_tongue:

for the stuttering, go grab the focboxtool.exe

go to motor settings -> FOC -> sensorless tab

crank up the openloop erpm in increments of 100


@barajabali Changed sensorless ERPM to 5000 under the hall sensor tab. Seemed to fix 1 motor?


Let me add a note: My motors have 3 diffrent colored cables Red, black and yellow

They are connected to the focbox like this: Motor1: red black yellow, motor2: yellow black red.

This should be the problem since this is only the direction of the motor?

Yea phase wire order only affects direction

1 Like

Wel the right motor seems to work now. But the left one still doesn’t

Another note:

Checking the duty cycle in the focbox tool: duty 1 is not changing on acceleration. duty 2 is now

Could you confirm your set it to senseless in the general tab? There’s two “General > sensor port” and “FOC > General > sensorless”