[Solved] Vesc can't connect to pc!

It was still working yesterday but then today it doesn’t connect to pc at all. Didn’t do anything on vesc or the usb 1.0 cable. My pc can’t even find it on any usb port… I need help please! Any indicator should turn on when it’s successfully connected? (don’t remember what it was like when it was still working)

Sorry, i don´t want to assume that you are stupid, but is your battery connected to the VESC? To my knowledge, the power from the USB-Port isn´t enough for the configuration of the VESC.

Another fact is that the VESC is very picky with the USB-Cables. Use a short one with good shielding.

check you device settings for the com port number. make sure you select the com port thats listed in devices.

1 Like

Cool mate.Yes it’s connected to space pro 4 first. Well actually I fucked up the cable I used yesterday which came from Enertion(steez) controller.

Cos even though the connecting head was longer then the ordinary one, somehow it was still bit short to charge the controller so I cut the edge thought it could be long enough but accidently tear it in half…

Is it possible because of this particular usb cable I broke so the vesc doesn’t connect to pc anymore? I should buy a new one?

device manager doesn’t show anything up when I connect the vesc to pc. BLDC tool only got com3 can pick and keep saying the firmware is too old I should update it (just because can’t read vesc)

So just to get this right:

You used to use the Enertion cable which always worked but now it´s broken and you tried another one which isn´t working? Then i would definitely say that the VESC doesn´t like your spare cable.

Usually there are a lot of these cables in a household. Do you have a Gopro or an old cardreader / external 2,5" harddrive with the same mini usb connector?

1 Like

well if it connects enough to say you need to update the firmware then its connected…

1 Like

Nice logic mate!

What I’ve got now are two cheap cables that I already forget where did they come from. But I tried my mate’s nikon camera usb cable and it doesn’t work.

So what I’m trying to say is WHAT IF I did something wrong to vesc cause the usb port doesn’t function anymore, any sign show on vesc? Just guessing.

BLDC tool shows nothing has been found so… :slight_frown:


Got no idea why but hey…all we want is the good result like this lol

1 Like

Good to hear that!

I like the braces box :smiley:

1 Like

Does enertion’s control use the same type of usb port? I thought it would have been the same as other controllers

I thought the controller would use Micro-B where as the VESC uses Mini-B

1 Like

It uses MINI-B!! And needs a extra long plug in order to reach the charging port…

1 Like

That obviously is not really the best solution for a charging port :confused: