Throttle range/travel too short on 2.4 Ghz mini remote

Hey Guys

I got a problem with the throttle-range on my 2.4 Ghz mini remote. The problem is, that I already reach full speed at 25% of throttle travel. This also happens if I’m on the board (75kg load). I’ve tried almost everything what was discussed in the forums. I’ve even bought a new remote (2.4 Ghz) changing from the nano remote to the mini remote. My setup is current control no reverse with break in PPM mode. Anyone has an idea to solve this problem within the BLDC tool form Benjamin Vedder? I’m using the latest version of the BLDC tool and a VESC from . Or is there calibration of the remote needed? Any advice to my specific problem would be highly appreciated.:blush:

Greeting from Switzerland Jan

If you’re using nano v2 read this

The mini remote for sure will work. You need to adjust the throttle curves and the PPM settings in the VESC Tool.


Is there really an option to ajust them in the tool? Or do I have to download this expansion from Ackmaniac? Would be really cool if you could send me a screenshot… Greetings Jan

I actually bought a 2.4 gHz mini remote from alieexpress. I though that would fix my problem because everybody was talking really good about it…

Is there really an option to ajust them in the tool? Or do I have to download this expansion from Ackmaniac? Would be really cool if you could send me a screenshot…

Greetings Jan

1 Like

under PPM tab ++> mapping ==> input deadband

this wording is using vesc tool, but should be same for ackmaniac

ackmaniac = App config ==> PPM ==> “pulsewidth” at bottom

if can adjust on remote would be easier i guess, its been awhile since i had to mess with that setting (in firmware) so memory foggy

Have you tried turning on remote first, then toggling the thumb control all the way up then all the way down, then turn on board?

Nop I’m going to try it will be back in a minute…

I’m actually using the BLDC tool. These are my settings, I really can’t see my mistake…

I tried it unfortunately it didn’t work :disappointed_relieved:

change value in “max pulsewidth” or “min pulsewidth” or both… id start with max setting

Edit: might even want to adjust “deadband” as far as tweaking what feels comfortable for your riding

When you pull the trigger all the way, what is the maximum pulsewidth? Then type that number into the box and it will make “100%” become that point

1 Like

Just use one of the newer firmwares where you have throttle curve and also not the old current control. Can use my bldc-tool mod 2.54 or my latest 3.101 or latest original from Vedder which is 3.38 if I am not wrong. All of them have a better control algorithm.

1 Like

I’m using 2.18 fw and BLDC tool with mini 2.4 remote. Throttle response and range are good. If you don’t want to change firmware and software, try following this tutorial to setup your remote with BLDC tool.

1 Like

I can also reach full speed at 25% throttle but the acceleration is slower, the speed control of a VESC is different than an ESC like the Evolve one, where you can set the speed by the throttle percentage.

That‘s exactly what I did. I tried it multiple times but in the end I always reached full speed at around 50% throttle range. What actually is the deadband setting for? I didn‘t change it, always left it on 0.25 ms…

Thats what I did all the time… I detected min/max pulsewith and tiped it into the boxes… still didn‘t work. Also the braking function is working in a really harsh way… way to strong to break safe (imagine me flipping of the board at 40 kmh😂). Any other ideas to fix the problem? In the end I‘m going to download Ackmaniacs firmware, as he suggested.

“deadband” is the position at witch throttle starts to kick in. (the grey area where nothing happens)

example: if .25 is 12 o clock and you increase to .50 would be 1 o clock

I‘m going to try to fix my problem with the modified tool from ackmaniac. If there‘s a new remote needed I‘ll get back to you👍 Ty very much