Trouble flashing updated firmware on FOCBOX

Hey guys, I know this is a pretty common topic but after reading dozens of threads I’m looking for some advice on what is going on. A little backstory, I fried the MCU in my FOCBOX and after replacing it the FOCBOX now powers on and I can connect to it. @CarlCollins was incredibly helpful getting the FOCBOX to connect to my computer and set up for my motor and hardware using the BLDC tool (turns out I didn’t have the right drivers on my computer). However I was wanting to try using the Ackmaniac tool or the new VESC Tool but when I connect to the FOCBOX it says that the firmware is out of date (which makes sense since I have 2.18 on the FOCBOX) so I go to the firmware tab, select “410 & 411 & 412” then the VESC_default.bin and click upload. It appears to upload but as soon as it completes it shows an error message (which I though was supposed to be normal) but never becomes available to connect to again. I have to pull the loop key and restart the ESC in order to get it to connect again and the firmware has not been updated. I’m not really sure what to do. I mean the board works and I can go ride no problem but I was wanting to try using Ackmaniac so I could play around with the Bluetooth connection to read info from the ESC. My only guesses now are that something is going on with the bootloader or maybe there is an issue with something else hardware wise on the board. I’m open to all suggestions to better understand what is going on here.

1 Like

I’m having the same issue as well - did you manage to resolve this? I have an ST-Link arriving to me in a few days from now.

Maybe the issue is that the FOCBOX doesn’t have a bootloader so one needs to be flashed to it? After flashing then it can be updated to a newer firmware to use VESC Tool as BLDC Tool is pretty much outdated.

Hopefully someone can help, otherwise I’ll sell these like-new FOCBOXs 2.18 FW on eBay and get a VESC as this is getting annoying.

What exactly is your problem and how it came to it? You also replaced the MCU or you just wanted to flash a new fw and now nothing is working anymore?

I acquired 2 like-new condition and fully functioning FOCBOXs, however I would like to use it on VESC Tool as BLDC Tool with FW 2.18 is lacking in some features that typically like with VESC Tool and newer FW.

The 2 units still work, but they refuse to update to later firmware. When I try to update, it just says 2.18 FW.

I’ve tried different methods of updating and using Ackmaniac FW and Extended BLDC Tool and VESC Tool Bootloader section with no luck at all. Last thing I’ll try is flashing the bootloader when I get the STW-Link in the next few days.

that´s strange, as Focboxes usually come with a bootloader on, so it shouldn´t be and issue to upgrade to fw 3.xx via VESC tool only. Hope it will work with the ST-Link than! I think you know that you first need to solder some jst- plug on the fockbox before you can use the ST-link (maybe not soldering, but as min fix it somehow in the PCB).

Yeah, that’s what I thought too! I’ll keep everyone posted on what happens when I receive the ST-Link.

Thanks for the info about the soldering heads up for the FOCBOX!

1 Like

you can find a good description here

just in case.

1 Like

Looks good! Will have to wait until I get the ST-Link.

Here’s what VESC Tool shows about the FOCBOX as there is no HW ID info. Only 2.18 FW, so pretty much no bootloader from what I saw in other posts.


If you one day will find out what “limited mode” means in the right down corner, let me please know. always interested to learn new things. maybe @CarlCollins our Focbox guru has a minute to have a look at your problem to update to a new FW.

1 Like

Limited mode means that only firmware section feature only works.

I had this issue with a Flipsky VESC that was on an older FW and updated it. Then all the other features worked.

1 Like

@MatrixWriter Looks like you just need to flash the firmware using normal flashing process Use default BLDC tool, then it will work Limited mode only shows when loaded firmware is older or newer than the supported one for VESC tool

For FOCBOX, I strongly recommend using BLDC tool from our website You can get them here: Windows Version: MAC Version:

1 Like

If you still want to use VESC tool You have to flash the supported firmware on it but this will void the warranty on your FOCBOX (platinum warranty excluded)

See the attached image! 2018-12-08_2050

If you are having issue that you are not able to flash the 3.1xx firmware on the FOCBOX Try using following method 1: Get the Vesc_default.bin from the VESC tool firmware directory and put it on your desktop 2: Run BLDC tool and select that file, perform a flash and then turn the setup off 3: Connect it again to PC and run VESC tool, then it will work :slight_smile:

1 Like

May i ask why you recommend bldc tool over vesc tool for the focbox? Vesc tool seems far more user friendly compared to the old bldc tool.

@Bjork3n We got reports from customers that Ackmaniac firmware cause issues with the FOCBOX but still not sure why That’s why we recommend default BLDC tool (Enertion Version)

Really? Thats weird since it seems to be to most common used Fw for the focboxes. So youre saying that enertion only recommends the 2.18fw and that people should avoid upgrading over 2.18fw on the focbox hardware?

@Bjork3n Upgrading to foreign firmware will void the warranty (default 60 days one only) so we always recommend 2.18 Noobs can stick to 2.18 and BLDC tool, professionals can use any firmware they want with the consequences :slight_smile:


I tried both methods of updating the FW and no luck from Carl’s instructions.

Decided to go with my original method - used ST-Link I got in the mail and flashed the bootloader hex file (Vedder forums for BLDC Bootloader download is broken so I had to compile my own – sucks) and got it updated to VESC FW 3.40. It’s much better than 2.18 and I have not had issues with it with my other VESCs that is on the latest FW.

Super annoyed that I had to go through this and that the FOCBOXs that I got did not have bootloader. I will make a YouTube tutorial video on flashing, troubleshooting and updating the FW for FOCBOXs since I have one more to flash.

TLDR: If you can’t update the FW and it only shows the version number without a UUID, you don’t have a bootloader, so it needs to be flashed.

PS: It isn’t recommended to connect the 3.3V line for the Link, power the VESC from your battery.

2018-12-09%2003_07_33-VESC%20Tool 2018-12-09%2004_09_14-VESC%20Tool


2018-12-09%2004_14_05-VESC%20Tool 2018-12-09%2004_14_24-VESC%20Tool


That’s odd, FOCBOX came with a bootloader I think there might be some other issue