Unknown Hall error: 255

I recently got two Racerstars 200kv with 5 wire sensors. To make them work with the vesc I soldered a 6 pin jst to it. Since the Temperatur signal is missing, I skipped this cable.

I want To run both motors in hybrid mode, so I started a new motor detection. Everything is fine expect the detection of the Hall Sensor.

It always shows me this message: unknown Hall error: 255. I don’t think I wired something wrong, that is why I’m even more angry that the Sensors not Working.

I already heard that running sensors in bldc hybrid mode is a hit or miss. But if it’s a miss can it ever go to a hit? Or do I have to dismiss my sensors?

I would be glad for any solution or advice! Thank you :slight_smile:

if you have a volt meter you could check all your sensor wires for breaks, sometimes tiny wires with shit insulation can break inside the insulation with no outward indication of having done so.

not to derail from your question but what does “hit or miss” mean exactly in regard to running BLDC hybrid?

Did you try to swap motor cables and redo hall sensor detection? That worked for me. If the motor spins backwards then you have a “invert motor direction” button in vesc tool.

thanks For your reply! Well that’s probably something I need to do. I also tried detecting the Hall sensors in the foc tab and the results are quite good I think. At least there is no error message.

I read This (hit or miss) in another thread and I think it simply means that either your sensors work or they don’t work with your vesc.

Unfortunately I have those shitty mt60 connectors which only allows one configuration of the phase wires.

But thank you for the advice, I will try that tonight :slight_smile:

I had something similar to this last night

One of my sensors must have died, checked all the wires continuity, they they’re all(halls) and (temp) sending a base volt but I get 0’s across the hall table now. So from vesc to the sensor board all is good…so something on the sensor board must have gone bad.

Verified it wasn’t the escs by using a different motor with sensors - which it detects. Motors probably have 1100 miles on them now. Shame the halls are epoxied to the windings, basically makes it unserviceable…ugh.

Well, i switched 2 phase wires and checked all sensor wires, but it doesnt help at all.

VESC Terminal I tried to use the “param_detect” function in the vesc tool and it gives me this:

Cycle integrator limit: 116.06 Coupling factor: 771.16 Hall sensor detection failed: -1, 5, -1, 4, 1, 6, 3, 4

BLDC Motor Detection: Integrator limit: 115.89 BEMF Coupling: 863.54 Unknown hall error: 255

FOC -Detect Hall Sensor

I’m pretty confused about the values written there as I dont know what they’re meaning.

Try to switch it again, there are 6 possible wire combinations, some motors doesn’t work with all.

In FOC the first and last number is always 255, this is no error, it’s normal.


Okay thank you! Im gonna try that. The only thing is that i have mt60 connector, so wiring 6 combinations is a ton of work :smile:
But let’s do this!

Your sensor and sensor port on the vesc is working in FOC so I guess it’s a matter of phase wire assignment to get it detected in BLDC. If you have single 3.5mm bullets you could solder short patch cables for testing, they fit into MT60.

Or you give FOC a try (200kv is the upper limit), my motors perform really bad in hybrid BLDC but very good in FOC, no cogging at all. But it depends on the quality of the hardware, too (eg. Maytech doesn’t run in FOC).

Which vesc firmware and tool are you using? I had problems with some versions of the vesc tool and firmware.

I’m pretty scared to use FOC cause I cant afford to damage my vesc. I got one axle and one vanda vesc. My battery cables are also longer than 30cm.

But I will test that 3.5mm bullets if i got some in my screw box.

Im using the latest vesc tool at the moment. Which version did you use?

So I tried every combination the three phase wires can give me. None of them is working. Anyone has an idea how I can check if the Sensor is working or not?

1 Like

If you want to check your hall sensors from the motor you can connect the pos. and neg. wire of your sensorplug with 5 volts. You can also use a 1s battery. Then you take a voltmeter and connect it to the pos. wire and one of the sensor wires. Turn your motor slowly and it should show you +5 volts or 0 volts (or less if you use a 1s battery), it depends if it is a pos. or neg. magnet next to the sensor. Check all three sensor wires.


Nice thank you! I’m gonna try that tomorrow :slight_smile:

I tried it today.

Every sensor wire from H1 to H3 shows me either 5 volt or 0 volt. Depending on the pos or neg magnet next to the sensor like you said

So I assume that the sensor is fine and so are my wirings.

But now I’m even more confused. What is the actual problem here?

1 Like

Can you you take pictures of the the sensor wires, splices, connectors

Sure, I will do everything to make it work :smiley:

Left Foto: from motor to 6 pin connector Right Foto: 6 pin connector

There’s definitely something up with your wiring…it’s giving me a headache looking at it…how many times is it split, theres an orange wire on the connector but I don’t see it in the other pic. I only see 5 wires…

Also on vesc, with connector on the far side from you, left to right, it’s gnd,h3,2,1,t,5v

You could ignore the white wire from the motor if there is no temp sensor which I’m sure there isnt

You have temp between H2 and H3 (actually H2 and H1). As scepterr said temp has to be next to +5V. I’m not sure about your pictures but if you have it connected like your drawing then it’s wrong.

Edit: Hmm, on the pictures it seems you connected it the right way.